version 1.7.3.0
[socat.git] / socat.spec
blob274a8eeb50834e70dfffdafb9d59d78fdc93614e
2 %define majorver 1.7
3 %define minorver 3.0
5 Summary: socat - multipurpose relay
6 Name: socat
7 Version: %{majorver}.%{minorver}
8 Release: 1
9 License: GPL
10 Group: Applications/Communications
11 Source0: http://www.dest-unreach.org/socat/download/socat-%{version}.tar.bz2
12 Requires: readline
13 Requires: openssl
14 BuildRoot: /var/tmp/%{name}-buildroot
16 %description
17 socat is a relay for bidirectional data transfer between two independent data
18 channels. Each of these data channels may be a file, pipe, device (terminal or
19 modem etc.), socket (UNIX, IP4, IP6 - raw, UDP, TCP), a file descriptor (stdin
20 etc.), a program, or an arbitrary combination of two of these.
22 %prep
23 %setup -n %{name}-%{version}
25 %build
26 # the CPPFLAGS setting is required for RedHat Linux
27 if [ -d /usr/kerberos/include ]; then
28 CPPFLAGS="-I/usr/kerberos/include" ./configure --prefix=%{_prefix} --mandir=%{_mandir}
29 else
30 ./configure --prefix=%{_prefix} --mandir=%{_mandir}
32 make
34 %install
35 rm -rf $RPM_BUILD_ROOT
37 mkdir -p $RPM_BUILD_ROOT%{_bindir}
38 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
40 make install DESTDIR=$RPM_BUILD_ROOT
42 %clean
43 rm -rf $RPM_BUILD_ROOT
45 %files
46 %defattr(-,root,root)
47 %doc README CHANGES EXAMPLES SECURITY doc/xio.help doc/socat.html FAQ BUGREPORTS
48 %doc COPYING COPYING.OpenSSL FILES PORTING DEVELOPMENT
49 %{_bindir}/socat
50 %{_bindir}/procan
51 %{_bindir}/filan
52 %{_mandir}/man1/socat.1*