5 Summary: socat
- multipurpose relay
7 Version: %{majorver}.%{minorver}
10 Group: Applications
/Communications
11 Source0: http
://www.dest
-unreach.org
/socat
/download
/socat
-%{version}.tar.bz2
14 BuildRoot: /var
/tmp
/%{name}-buildroot
17 socat is a relay
for bidirectional data transfer between two independent data
18 channels. Each of these data channels may be a file
, pipe
, device
(terminal or
19 modem etc.
), socket
(UNIX
, IP4
, IP6
- raw
, UDP
, TCP
), a file descriptor
(stdin
20 etc.
), a program
, or an arbitrary combination of two of these.
23 %setup -n
%{name}-%{version}
26 # the CPPFLAGS setting is required for RedHat Linux
27 if [ -d
/usr
/kerberos
/include
]; then
28 CPPFLAGS
="
-I
/usr
/kerberos
/include" .
/configure
--prefix
=%{_prefix} --mandir=%{_mandir}
30 .
/configure
--prefix
=%{_prefix} --mandir=%{_mandir}
35 rm -rf $RPM_BUILD_ROOT
37 mkdir -p $RPM_BUILD_ROOT
%{_bindir}
38 mkdir -p $RPM_BUILD_ROOT
%{_mandir}/man1
40 make install DESTDIR
=$RPM_BUILD_ROOT
41 mv $RPM_BUILD_ROOT
%{_bindir}/socat $RPM_BUILD_ROOT%{_bindir}/socat1
42 mv $RPM_BUILD_ROOT
%{_mandir}/man1/socat.1 $RPM_BUILD_ROOT%{_mandir}/man1
/socat1.1
45 rm -rf $RPM_BUILD_ROOT
49 %doc README CHANGES EXAMPLES SECURITY doc
/socat.html FAQ BUGREPORTS
50 %doc COPYING COPYING.OpenSSL FILES PORTING DEVELOPMENT
55 %{_mandir}/man1
/socat1.1
58 ln
-s
-f socat1
%{_binddir}/socat
59 ln
-s
-f socat1.1
%{_mandir}/man1
/socat
.1
62 rm -f
%{_bindir}/socat
63 rm -f
%{_mandir}/man1
/socat
.1