2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
8 # This is the debhelper compatibility version to use.
11 # These are used for cross-compiling and for saving the configure script
12 # from having to guess our platform (since we know it already)
13 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
14 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
17 ifneq (,$(findstring debug
,$(DEB_BUILD_OPTIONS
)))
20 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
24 config.status
: configure
26 # Add here commands to configure the package.
27 .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) --prefix=/usr
--mandir=\
$${prefix}/share
/man
--infodir=\
$${prefix}/share
/info
32 build-stamp
: config.status
35 # Add here commands to compile the package.
37 #/usr/bin/docbook-to-man debian/wmwifi-0.1.sgml > wmwifi-0.1.1
46 # Add here commands to clean up after the build process.
48 -test -r
/usr
/share
/misc
/config.sub
&& \
49 cp
-f
/usr
/share
/misc
/config.sub config.sub
50 -test -r
/usr
/share
/misc
/config.guess
&& \
51 cp
-f
/usr
/share
/misc
/config.guess config.guess
62 # Add here commands to install the package into debian/wmwifi-0.1.
63 $(MAKE
) install prefix=$(CURDIR
)/debian
/wmwifi
/usr
66 # Build architecture-independent files here.
67 binary-indep
: build
install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch
: build
install
77 dh_installman wmwifi
.1
90 binary
: binary-indep binary-arch
91 .PHONY
: build
clean binary-indep binary-arch binary
install