wmbutton: initTooltip has no argument
[dockapps.git] / wmwifi / debian / rules
blob4c2dc961a257a4550b5b49f56b4a75ce43ef64c1
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=3
11 # These are used for cross-compiling and for saving the configure script
12 # from having to guess our platform (since we know it already)
13 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
14 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -g
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21 INSTALL_PROGRAM += -s
22 endif
24 config.status: configure
25 dh_testdir
26 # Add here commands to configure the package.
27 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
30 build: build-stamp
32 build-stamp: config.status
33 dh_testdir
35 # Add here commands to compile the package.
36 $(MAKE)
37 #/usr/bin/docbook-to-man debian/wmwifi-0.1.sgml > wmwifi-0.1.1
39 touch build-stamp
41 clean:
42 dh_testdir
43 dh_testroot
44 rm -f build-stamp
46 # Add here commands to clean up after the build process.
47 -$(MAKE) distclean
48 -test -r /usr/share/misc/config.sub && \
49 cp -f /usr/share/misc/config.sub config.sub
50 -test -r /usr/share/misc/config.guess && \
51 cp -f /usr/share/misc/config.guess config.guess
54 dh_clean
56 install: build
57 dh_testdir
58 dh_testroot
59 dh_clean -k
60 dh_installdirs
62 # Add here commands to install the package into debian/wmwifi-0.1.
63 $(MAKE) install prefix=$(CURDIR)/debian/wmwifi/usr
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch: build install
72 dh_testdir
73 dh_testroot
74 dh_installdocs
75 dh_installexamples
76 dh_installmenu
77 dh_installman wmwifi.1
78 dh_installinfo
79 dh_installchangelogs
80 dh_link
81 dh_strip
82 dh_compress
83 dh_fixperms
84 dh_installdeb
85 dh_shlibdeps
86 dh_gencontrol
87 dh_md5sums
88 dh_builddeb
90 binary: binary-indep binary-arch
91 .PHONY: build clean binary-indep binary-arch binary install