3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
17 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
23 configure
: configure-stamp
26 # Add here commands to configure the package.
33 build-stamp
: configure-stamp
36 # Add here commands to compile the package.
38 #docbook-to-man debian/stgit.sgml > stgit.1
45 rm -f build-stamp configure-stamp
47 # Add here commands to clean up after the build process.
58 # Add here commands to install the package into debian/stgit.
59 $(MAKE
) DESTDIR
=$(CURDIR
)/debian
/stgit PREFIX
=/usr
install
61 # Build architecture-independent files here.
62 binary-indep
: build
install
63 # We have nothing to do by default.
65 # Build architecture-dependent files here.
66 binary-arch
: build
install
96 binary
: binary-indep binary-arch
97 .PHONY
: build
clean binary-indep binary-arch binary
install configure