NTLM: flagged out NTLMv1 from production code
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob2f3b31e85fc49cb90d33e8dc9667f6e7c1eab3c5
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define protocol purple-sipe
21 Name: pidgin-sipe
22 Summary: Pidgin third-party plugin for Microsoft LCS/OCS
23 Version: 1.8.1
24 %if 0%{?_with_git:1}
25 Release: %{gitcount}.%{git}%{?dist}
26 Source: %{name}-%{git}.tar.bz2
27 # git package overrides official released package
28 Epoch: 1
29 %else
30 Release: 1%{?dist}
31 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
32 %endif
33 Group: Applications/Internet
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
39 BuildRequires: libpurple-devel >= 2.3.1, libtool, intltool, gettext-devel
41 # Configurable components
42 %if !0%{?_without_kerberos:1}
43 %define config_krb5 --with-krb5
44 BuildRequires: krb5-devel
45 %endif
47 Requires: %{protocol} = %{?epoch:%{epoch}:}%{version}-%{release}
50 %description
51 A third-party plugin for the Pidgin multi-protocol instant messenger. It
52 implements the extended version of SIP/SIMPLE used by various products:
54 * Microsoft Office Communications Server (OCS 2007 and newer)
55 * Microsoft Live Communications Server (LCS 2003/2005)
56 * Reuters Messaging
58 This package provides the icon set for Pidgin.
61 %package -n %{protocol}
62 Summary: Libpurple third-party plugin for Microsoft LCS/OCS
63 Group: Applications/Internet
65 %description -n %{protocol}
66 A third-party plugin for the libpurple multi-protocol instant messaging core.
67 It implements the extended version of SIP/SIMPLE used by various products:
69 * Microsoft Office Communications Server (OCS 2007 and newer)
70 * Microsoft Live Communications Server (LCS 2003/2005)
71 * Reuters Messaging
74 %prep
75 %if 0%{?_with_git:1}
76 %setup -q -n %{name}-%{git}
77 %else
78 %setup -q
79 %endif
82 %build
83 %if 0%{?_with_git:1}
84 ./autogen.sh
85 %endif
86 %configure \
87 %{?config_krb5:%{config_krb5}} \
88 --with-purple \
89 --without-telepathy
90 make %{_smp_mflags}
93 %install
94 %makeinstall
95 %find_lang %{name}
97 # NOTE: We intentionally don't ship *.la files
98 find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
101 %clean
102 rm -rf $RPM_BUILD_ROOT
105 %files -n %{protocol} -f %{name}.lang
106 %defattr(-,root,root,-)
107 %doc AUTHORS ChangeLog COPYING NEWS README TODO
108 %{_libdir}/purple-2/libsipe.so
111 %files
112 %defattr(-,root,root,-)
113 %doc AUTHORS COPYING
114 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
117 %changelog
118 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
119 - update to 1.8.1
121 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
122 - update to 1.8.0
124 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
125 - autogen.sh no longer runs configure
127 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
128 - add configure parameters for purple and telepathy
130 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
131 - add Epoch: for git packages to avoid update clash with official packages
133 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
134 - update to 1.7.1
136 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
137 - add missing Group: to purple-sipe
139 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
140 - update to 1.7.0
142 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
143 - move non-Pidgin files to new sub-package purple-sipe
145 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
146 - remove directory for emoticon theme icons
148 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
149 - libpurple protocol plugins are located under %{_libdir}/purple-2
151 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
152 - added directory for emoticon theme icons
154 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
155 - update to 1.6.3
157 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
158 - reduce libpurple-devel requirement to >= 2.3.1
160 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
161 - update to 1.6.2
163 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
164 - reduce libpurple-devel requirement to >= 2.4.1
166 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
167 - com_err.h only required for kerberos
169 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
170 - require libpurple-devel >= 2.5.0
172 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
173 - refactor configure parameters
174 - make kerberos configurable
175 - don't hard code prefix for git builds
177 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
178 - removed unnecessary zlib-devel
180 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
181 - fix prefix for git builds
183 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
184 - append -Wno-unused-parameter for GCC <4.4 compilation errors
186 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
187 - remove duplicate GPL2
189 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
190 - use "--with git" to build from git
191 - corrected download URL for release archive
192 - add missing BR gettext-devel
194 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
195 - use default rpmbuild CFLAGS also for git builds
196 - merge with SPEC files created by mricon & jberanek
198 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
199 - initial RPM SPEC example generated