Release 1.25.0 -- Buddy Idle Time, RTF
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobdebb8266403e61f33e4dc785d9d46864e1f6f466
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20180827git1297745c
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.25.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: https://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0-or-later
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(dbus-1)
43 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
44 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(nss)
47 BuildRequires: pkgconfig(purple) >= 2.7.0
48 %if 0%{?_with_git:1}
49 BuildRequires: autoconf
50 BuildRequires: automake
51 BuildRequires: flex
52 %endif
53 BuildRequires: appstream
54 BuildRequires: gcc
55 BuildRequires: gettext
56 BuildRequires: intltool
57 BuildRequires: libtool
58 # Use "--without vv" to disable Voice & Video features
59 %if !0%{?_without_vv:1}
60 BuildRequires: pkgconfig(purple) >= 2.8.0
61 BuildRequires: pkgconfig(farstream-0.2)
62 BuildRequires: pkgconfig(freerdp-shadow2)
63 BuildRequires: pkgconfig(gio-2.0)
64 BuildRequires: pkgconfig(gstreamer-1.0)
65 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
66 BuildRequires: pkgconfig(nice) >= 0.1.0
67 %endif
68 # Use "--without telepathy" to disable telepathy
69 %if !0%{?_without_telepathy:1}
70 BuildRequires: gmime-devel
71 BuildRequires: pkgconfig(dbus-glib-1)
72 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
73 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
74 BuildRequires: pkgconfig(gobject-2.0)
75 BuildRequires: pkgconfig(telepathy-glib) >= 0.24.0
76 %endif
78 # Configurable components
79 # Use "--without kerberos" to disable krb5
80 %if !0%{?_without_kerberos:1}
81 BuildRequires: pkgconfig(krb5)
82 %if 0%{?fedora} || 0%{?rhel} >= 7
83 BuildRequires: gssntlmssp-devel >= 0.5.0
84 %define requires_gssntlmssp 1
85 %endif
86 %endif
88 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
91 %description
92 A third-party plugin for the Pidgin multi-protocol instant messenger.
93 It implements the extended version of SIP/SIMPLE used by various products:
95 * Skype for Business
96 * Microsoft Office 365
97 * Microsoft Business Productivity Online Suite (BPOS)
98 * Microsoft Lync Server
99 * Microsoft Office Communications Server (OCS 2007/2007 R2)
100 * Microsoft Live Communications Server (LCS 2003/2005)
102 With this plugin you should be able to replace your Microsoft Office
103 Communicator client with Pidgin.
105 This package provides the icon set for Pidgin.
108 %package -n %{purple_plugin}
109 Summary: Libpurple protocol plugin to connect to MS Office Communicator
110 Group: %{pkg_group}
111 License: GPL-2.0-or-later
112 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
114 %if 0%{?requires_gssntlmssp}
115 Requires: gssntlmssp >= 0.5.0
116 %endif
118 %description -n %{purple_plugin}
119 A third-party plugin for the Pidgin multi-protocol instant messenger.
120 It implements the extended version of SIP/SIMPLE used by various products:
122 * Skype for Business
123 * Microsoft Office 365
124 * Microsoft Business Productivity Online Suite (BPOS)
125 * Microsoft Lync Server
126 * Microsoft Office Communications Server (OCS 2007/2007 R2)
127 * Microsoft Live Communications Server (LCS 2003/2005)
129 This package provides the protocol plugin for libpurple clients.
132 %if !0%{?_without_telepathy:1}
133 %package -n %{empathy_files}
134 Summary: Telepathy connection manager to connect to MS Office Communicator
135 Group: %{pkg_group}
136 License: GPL-2.0-or-later
137 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
139 %description -n %{empathy_files}
140 A Telepathy connection manager that implements the extended version of
141 SIP/SIMPLE used by various products:
143 * Skype for Business
144 * Microsoft Office 365
145 * Microsoft Business Productivity Online Suite (BPOS)
146 * Microsoft Lync Server
147 * Microsoft Office Communications Server (OCS 2007/2007 R2)
148 * Microsoft Live Communications Server (LCS 2003/2005)
150 This package provides the icon set for Empathy.
153 %package -n %{ktp_files}
154 Summary: Telepathy connection manager to connect to MS Office Communicator
155 Group: %{pkg_group}
156 License: GPL-2.0-or-later
157 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
159 %description -n %{ktp_files}
160 A Telepathy connection manager that implements the extended version of
161 SIP/SIMPLE used by various products:
163 * Skype for Business
164 * Microsoft Office 365
165 * Microsoft Business Productivity Online Suite (BPOS)
166 * Microsoft Lync Server
167 * Microsoft Office Communications Server (OCS 2007/2007 R2)
168 * Microsoft Live Communications Server (LCS 2003/2005)
170 This package provides the profile for KTP account manager.
173 %package -n %{telepathy_plugin}
174 Summary: Telepathy connection manager to connect to MS Office Communicator
175 Group: %{pkg_group}
176 License: GPL-2.0-or-later
177 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
179 %if 0%{?requires_gssntlmssp}
180 Requires: gssntlmssp >= 0.5.0
181 %endif
183 %description -n %{telepathy_plugin}
184 A Telepathy connection manager that implements the extended version of
185 SIP/SIMPLE used by various products:
187 * Skype for Business
188 * Microsoft Office 365
189 * Microsoft Business Productivity Online Suite (BPOS)
190 * Microsoft Lync Server
191 * Microsoft Office Communications Server (OCS 2007/2007 R2)
192 * Microsoft Live Communications Server (LCS 2003/2005)
194 This package provides the protocol support for Telepathy clients.
195 %endif
198 %package -n %{common_files}
199 Summary: Common files for SIPE protocol plugins
200 Group: %{pkg_group}
201 License: GPL-2.0-or-later
202 BuildArch: noarch
204 %description -n %{common_files}
205 This package provides common files for the SIPE protocol plugins:
207 * Localisation
210 %prep
211 %if 0%{?_with_git:1}
212 %setup -q -n %{name}-%{git}
213 %else
214 %setup -q
215 %endif
218 %build
219 %if 0%{?_with_git:1}
220 ./autogen.sh
221 %endif
222 %configure \
223 %if 0%{?_without_vv:1}
224 --without-vv \
225 %endif
226 %if !0%{?_without_kerberos:1}
227 --with-krb5 \
228 %endif
229 --enable-purple \
230 %if !0%{?_without_telepathy:1}
231 --enable-telepathy
232 %else
233 --disable-telepathy
234 %endif
235 make %{?_smp_mflags}
238 %install
239 %make_install
240 find %{buildroot} -type f -name "*.la" -delete -print
241 # Pidgin doesn't have 24 or 32 pixel icons
242 rm -f \
243 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
244 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
245 %find_lang %{name}
248 %check
249 make %{?_smp_mflags} check
252 %files -n %{purple_plugin}
253 %defattr(-,root,root,-)
254 %doc AUTHORS ChangeLog COPYING NEWS README TODO
255 %{_libdir}/purple-2/libsipe.so
258 %if !0%{?_without_telepathy:1}
259 %files -n %{empathy_files}
260 %defattr(-,root,root,-)
261 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
262 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
265 %files -n %{ktp_files}
266 %defattr(-,root,root,-)
267 %doc AUTHORS COPYING
268 %{_datadir}/telepathy/profiles/sipe.profile
271 %files -n %{telepathy_plugin}
272 %defattr(-,root,root,-)
273 %doc AUTHORS ChangeLog COPYING NEWS README TODO
274 %{_datadir}/dbus-1/services/*.sipe.service
275 %{_libexecdir}/telepathy-sipe
276 %endif
279 %files -n %{common_files} -f %{name}.lang
280 %defattr(-,root,root,-)
283 %files
284 %defattr(-,root,root,-)
285 %{_datadir}/metainfo/%{name}.metainfo.xml
286 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
287 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
290 %changelog
291 * Sat Oct 12 2019 J. D. User <jduser@noreply.com> 1.25.0
292 - update to 1.25.0
294 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
295 - switch to SPDX identifier GPL-2.0-or-later
297 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
298 - raise BR telepathy-glib >= 0.24.0
300 * Fri Dec 28 2018 J. D. User <jduser@noreply.com> 1.24.0-*git*
301 - add BR flex for git builds
303 * Sat Nov 10 2018 J. D. User <jduser@noreply.com> 1.24.0
304 - update to 1.24.0
306 * Mon Aug 27 2018 J. D. User <jduser@noreply.com> 1.23.3-*git*
307 - add BR freerdp-shadow2
309 * Mon Aug 20 2018 J. D. User <jduser@noreply.com> 1.23.3
310 - update to 1.23.3
312 * Sat Mar 10 2018 J. D. User <jduser@noreply.com> 1.23.2
313 - update to 1.23.2
315 * Sun Feb 25 2018 J. D. User <jduser@noreply.com> 1.23.1
316 - update to 1.23.1
318 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
319 - remove obsolete clean section
321 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
322 - change source URL to https://
324 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
325 - add BR gcc
327 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
328 - add BR appstream
330 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
331 - add support for new AppStream metadata file location
333 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
334 - update to 1.23.0
335 - raise BR glib-2.0 >= 2.18.0
336 - raise BR purple >= 2.7.0
338 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
339 - add BR dbus-1
341 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
342 - update to 1.22.1
344 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
345 - update to 1.22.0
347 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
348 - add BR gio-2.0
350 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
351 - add BR farstream-0.2
353 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
354 - update to 1.21.1
356 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
357 - update to 1.21.0
359 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
360 - align with Fedora SPEC file
362 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
363 - add AppStream metadata file
365 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
366 - add dependency on pkgconfig(gstreamer-1.0) for F22+
368 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
369 - update to 1.20.1
371 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
372 - we also support "Skype for Business"
374 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
375 - update to 1.20.0
377 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
378 - update to 1.19.1
380 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
381 - update to 1.19.0
383 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
384 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
385 - enable Voice & Video features by default
386 - move dependency on libnice-gstreamer to correct packages
388 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
389 - update to 1.18.5
391 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
392 - update to 1.18.4
394 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
395 - update to 1.18.3
397 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
398 - update to 1.18.2
400 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
401 - update to 1.18.1
403 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
404 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
406 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
407 - F20+ require libnice-gstreamer for correct operation
409 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
410 - update to 1.18.0
412 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
413 - update to 1.17.3
415 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
416 - update to 1.17.2
418 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
419 - update to 1.17.1
421 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
422 - update to 1.17.0
424 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
425 - update to 1.16.1
427 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
428 - update to 1.16.0
430 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
431 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
433 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
434 - update to 1.15.1
436 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
437 - update package description texts
439 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
440 - update to 1.15.0
442 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
443 - update to 1.14.1
445 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
446 - update to 1.14.0
448 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
449 - BR telepathy-glib-devel >= 0.18.0
451 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
452 - BR telepathy-glib-devel >= 0.14.0
454 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
455 - add ktp-accounts-kcm-sipe package
457 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
458 - telepathy now requires glib-2.0 >= 2.22.0
459 - use "--without telepathy" to disable telepathy packages
461 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
462 - add empathy-sipe package
464 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
465 - add telepathy-sipe & sipe-common packages
467 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
468 - update to 1.13.3
470 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
471 - update to 1.13.2
473 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
474 - update to 1.13.1
476 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
477 - update to 1.13.0
479 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
480 - we do support Microsoft Lync Server 2010 now.
482 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
483 - update GPL2 license name
485 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
486 - add BR gmime-devel
488 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
489 - add BR nss-devel
491 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
492 - update to 1.12.0
494 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
495 - add "--with vv" option to enable Voice & Video features
497 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
498 - update to 1.11.2
500 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
501 - update to 1.11.1
503 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
504 - update to 1.11.0
506 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
507 - add (commented out) BR libnice-devel
509 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
510 - update to 1.10.1
512 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
513 - add (commented out) BR nss-devel
515 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
516 - update to 1.10.0
518 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
519 - changed --with/--without options to --enable/--disable
521 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
522 - removed --with-krb5 configure option as it is autodetected now
524 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
525 - add SVG icon
527 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
528 - add BR glib2-devel >= 2.12.0
530 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
531 - add tests to build
533 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
534 - update to 1.9.1
536 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
537 - add BR libxml2-devel
539 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
540 - update to 1.9.0
542 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
543 - increased libpurple build requisite to >= 2.4.0
545 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
546 - sync with RPM SPEC from contrib/OBS
548 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
549 - update package summary & description
551 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
552 - update to 1.8.1
554 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
555 - update to 1.8.0
557 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
558 - autogen.sh no longer runs configure
560 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
561 - add configure parameters for purple and telepathy
563 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
564 - add Epoch: for git packages to avoid update clash with official packages
566 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
567 - update to 1.7.1
569 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
570 - add missing Group: to purple-sipe
572 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
573 - update to 1.7.0
575 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
576 - move non-Pidgin files to new sub-package purple-sipe
578 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
579 - remove directory for emoticon theme icons
581 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
582 - libpurple protocol plugins are located under %%{_libdir}/purple-2
584 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
585 - added directory for emoticon theme icons
587 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
588 - update to 1.6.3
590 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
591 - reduce libpurple-devel requirement to >= 2.3.1
593 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
594 - update to 1.6.2
596 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
597 - reduce libpurple-devel requirement to >= 2.4.1
599 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
600 - com_err.h only required for kerberos
602 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
603 - require libpurple-devel >= 2.5.0
605 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
606 - refactor configure parameters
607 - make kerberos configurable
608 - don't hard code prefix for git builds
610 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
611 - removed unnecessary zlib-devel
613 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
614 - fix prefix for git builds
616 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
617 - append -Wno-unused-parameter for GCC <4.4 compilation errors
619 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
620 - remove duplicate GPL2
622 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
623 - use "--with git" to build from git
624 - corrected download URL for release archive
625 - add missing BR gettext-devel
627 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
628 - use default rpmbuild CFLAGS also for git builds
629 - merge with SPEC files created by mricon & jberanek
631 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
632 - initial RPM SPEC example generated