2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git
20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
16 #------------------------------- BUILD FROM GIT -------------------------------
19 %define purple_plugin purple
-sipe
20 %define pkg_group Applications
/Internet
23 Summary: Pidgin protocol plugin to connect to MS Office Communicator
26 Release: %{gitcount}.%{git}%{?dist}
27 Source: %{name}-%{git}.tar.bz2
28 # git package overrides official released package
32 Source: http
://downloads.sourceforge.net
/sipe
/%{name}-%{version}.tar.bz2
36 URL: http
://sipe.sourceforge.net
/
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
40 BuildRequires
: libpurple
-devel
>= 2.4.0
41 BuildRequires
: libtool
42 BuildRequires
: intltool
43 BuildRequires
: gettext
-devel
45 # Configurable components
46 %if !0%{?_without_kerberos:1}
47 %define config_krb5
--with
-krb5
48 BuildRequires
: krb5
-devel
51 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
55 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
56 It implements the extended version of SIP
/SIMPLE used by various products
:
58 * Microsoft Office Communications Server
(OCS
2007/2007 R2 and newer
)
59 * Microsoft Live Communications Server
(LCS
2003/2005)
62 With this plugin you should be able to replace your Microsoft Office
63 Communicator client with Pidgin.
65 This package provides the icon
set for Pidgin.
68 %package -n
%{purple_plugin}
69 Summary: Libpurple protocol plugin to connect to MS Office Communicator
73 %description -n
%{purple_plugin}
74 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
75 It implements the extended version of SIP
/SIMPLE used by various products
:
77 * Microsoft Office Communications Server
(OCS
2007/2007 R2 and newer
)
78 * Microsoft Live Communications Server
(LCS
2003/2005)
81 This package provides the protocol plugin
for libpurple clients.
86 %setup -q
-n
%{name}-%{git}
97 %{?config_krb5:%{config_krb5}} \
105 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
113 %files -n
%{purple_plugin} -f %{name}.lang
114 %defattr(-,root
,root
,-)
115 %doc AUTHORS ChangeLog COPYING NEWS README TODO
116 %{_libdir}/purple
-2/libsipe.so
120 %defattr(-,root
,root
,-)
122 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
126 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
129 * Wed Mar
10 2010 J. D. User
<jduser@noreply.com
> 1.9.0
132 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
133 - increased libpurple build requisite to
>= 2.4.0
135 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
136 - sync with RPM SPEC from contrib
/OBS
138 * Sat Mar
06 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
139 - update package summaary
& description
141 * Tue Feb
16 2010 J. D. User
<jduser@noreply.com
> 1.8.1
144 * Sun Feb
07 2010 J. D. User
<jduser@noreply.com
> 1.8.0
147 * Thu Jan
14 2010 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
148 - autogen.sh no longer runs configure
150 * Tue Dec
29 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
151 - add configure parameters
for purple and telepathy
153 * Sat Dec
12 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
154 - add Epoch
: for git packages to avoid update clash with official packages
156 * Mon Nov
19 2009 J. D. User
<jduser@noreply.com
> 1.7.1
159 * Mon Oct
28 2009 J. D. User
<jduser@noreply.com
> 1.7.0-*git
*
160 - add missing
Group: to purple
-sipe
162 * Mon Oct
19 2009 J. D. User
<jduser@noreply.com
> 1.7.0
165 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
166 - move non
-Pidgin files to new sub
-package purple
-sipe
168 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
169 - remove directory
for emoticon theme icons
171 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
172 - libpurple protocol plugins are located under
%{_libdir}/purple
-2
174 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
175 - added directory
for emoticon theme icons
177 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
180 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
181 - reduce libpurple
-devel requirement to
>= 2.3.1
183 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
186 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
187 - reduce libpurple
-devel requirement to
>= 2.4.1
189 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
190 - com_err.h only required
for kerberos
192 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
193 - require libpurple
-devel
>= 2.5.0
195 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
196 - refactor configure parameters
197 - make kerberos configurable
198 - don't hard code prefix
for git builds
200 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
201 - removed unnecessary zlib
-devel
203 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
204 - fix prefix
for git builds
206 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
207 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
209 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
210 - remove duplicate GPL2
212 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
213 - use "
--with git" to build from git
214 - corrected download
URL for release archive
215 - add missing BR gettext
-devel
217 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
218 - use default rpmbuild CFLAGS also
for git builds
219 - merge with SPEC files created by mricon
& jberanek
221 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
222 - initial RPM SPEC example generated