Update documentation and packaging files
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob06cbe7e96290257bf6f9668a9788b468f50ee582
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define protocol purple-sipe
21 Name: pidgin-sipe
22 Summary: Pidgin protocol plugin to connect to MS Office Communicator
23 Version: 1.8.1
24 %if 0%{?_with_git:1}
25 Release: %{gitcount}.%{git}%{?dist}
26 Source: %{name}-%{git}.tar.bz2
27 # git package overrides official released package
28 Epoch: 1
29 %else
30 Release: 1%{?dist}
31 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
32 %endif
33 Group: Applications/Internet
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
39 BuildRequires: libpurple-devel >= 2.3.1, libtool, intltool, gettext-devel
41 # Configurable components
42 %if !0%{?_without_kerberos:1}
43 %define config_krb5 --with-krb5
44 BuildRequires: krb5-devel
45 %endif
47 Requires: %{protocol} = %{?epoch:%{epoch}:}%{version}-%{release}
50 %description
51 A third-party plugin for the Pidgin multi-protocol instant messenger.
52 It implements the extended version of SIP/SIMPLE used by various products:
54 * Microsoft Office Communications Server (OCS 2007/2007R2 and newer)
55 * Microsoft Live Communications Server (LCS 2003/2005)
56 * Reuters Messaging
58 With this plugin you should be able to replace your Microsoft Office
59 Communicator client with Pidgin.
61 This package provides the icon set for Pidgin.
64 %package -n %{protocol}
65 Summary: Libpurple third-party plugin for Microsoft LCS/OCS
66 Group: Applications/Internet
68 %description -n %{protocol}
69 A third-party plugin for the Pidgin multi-protocol instant messenger.
70 It implements the extended version of SIP/SIMPLE used by various products:
72 * Microsoft Office Communications Server (OCS 2007/2007R2 and newer)
73 * Microsoft Live Communications Server (LCS 2003/2005)
74 * Reuters Messaging
76 With this plugin you should be able to replace your Microsoft Office
77 Communicator client with Pidgin.
80 %prep
81 %if 0%{?_with_git:1}
82 %setup -q -n %{name}-%{git}
83 %else
84 %setup -q
85 %endif
88 %build
89 %if 0%{?_with_git:1}
90 ./autogen.sh
91 %endif
92 %configure \
93 %{?config_krb5:%{config_krb5}} \
94 --with-purple \
95 --without-telepathy
96 make %{_smp_mflags}
99 %install
100 %makeinstall
101 %find_lang %{name}
103 # NOTE: We intentionally don't ship *.la files
104 find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
107 %clean
108 rm -rf $RPM_BUILD_ROOT
111 %files -n %{protocol} -f %{name}.lang
112 %defattr(-,root,root,-)
113 %doc AUTHORS ChangeLog COPYING NEWS README TODO
114 %{_libdir}/purple-2/libsipe.so
117 %files
118 %defattr(-,root,root,-)
119 %doc AUTHORS COPYING
120 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
123 %changelog
124 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
125 - update package summaary & description
127 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
128 - update to 1.8.1
130 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
131 - update to 1.8.0
133 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
134 - autogen.sh no longer runs configure
136 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
137 - add configure parameters for purple and telepathy
139 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
140 - add Epoch: for git packages to avoid update clash with official packages
142 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
143 - update to 1.7.1
145 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
146 - add missing Group: to purple-sipe
148 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
149 - update to 1.7.0
151 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
152 - move non-Pidgin files to new sub-package purple-sipe
154 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
155 - remove directory for emoticon theme icons
157 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
158 - libpurple protocol plugins are located under %{_libdir}/purple-2
160 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
161 - added directory for emoticon theme icons
163 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
164 - update to 1.6.3
166 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
167 - reduce libpurple-devel requirement to >= 2.3.1
169 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
170 - update to 1.6.2
172 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
173 - reduce libpurple-devel requirement to >= 2.4.1
175 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
176 - com_err.h only required for kerberos
178 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
179 - require libpurple-devel >= 2.5.0
181 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
182 - refactor configure parameters
183 - make kerberos configurable
184 - don't hard code prefix for git builds
186 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
187 - removed unnecessary zlib-devel
189 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
190 - fix prefix for git builds
192 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
193 - append -Wno-unused-parameter for GCC <4.4 compilation errors
195 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
196 - remove duplicate GPL2
198 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
199 - use "--with git" to build from git
200 - corrected download URL for release archive
201 - add missing BR gettext-devel
203 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
204 - use default rpmbuild CFLAGS also for git builds
205 - merge with SPEC files created by mricon & jberanek
207 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
208 - initial RPM SPEC example generated