Updated to release 1.6.3
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobcdff1c934ba3edfbaaf52da4563c551bafac8da2
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20090817gitc92a59a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 Name: pidgin-sipe
20 Summary: Pidgin plugin for connecting to Microsoft LCS/OCS
21 Version: 1.6.3
22 %if 0%{?_with_git:1}
23 Release: %{gitcount}.%{git}%{?dist}
24 Source: %{name}-%{git}.tar.bz2
25 %else
26 Release: 1%{?dist}
27 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
28 %endif
29 Group: Applications/Internet
30 License: GPLv2+
31 URL: http://sipe.sourceforge.net/
33 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
35 BuildRequires: libpurple-devel >= 2.3.1, libtool, intltool, gettext-devel
37 # Configurable components
38 %if !0%{?_without_kerberos:1}
39 %define config_krb5 --with-krb5
40 BuildRequires: krb5-devel
41 %endif
44 %description
45 Provides an Open Implementation of SIP/Simple protocol for connecting Pidgin to
46 Live Communications Server 2003/2005 and Office Communications Server 2007.
49 %prep
50 %if 0%{?_with_git:1}
51 %setup -q -n %{name}-%{git}
52 %else
53 %setup -q
54 %endif
57 %build
58 %define config_params %{?config_krb5:%{config_krb5}}
59 %if 0%{?_with_git:1}
60 # Copied from "rpmbuild --showrc" configure definition
61 export CFLAGS="${CFLAGS:-%optflags}"
62 ./autogen.sh --build=%{_build} --host=%{_host} \
63 --target=%{_target_platform} \
64 --prefix=%{_prefix} \
65 --datadir=%{_datadir} \
66 --libdir=%{_libdir} \
67 %{config_params}
68 %else
69 %configure %{config_params}
70 %endif
72 make %{_smp_mflags}
75 %install
76 %makeinstall
77 %find_lang %{name}
79 # NOTE: We intentionally don't ship *.la files
80 find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
83 %clean
84 rm -rf $RPM_BUILD_ROOT
87 %files -f %{name}.lang
88 %defattr(-,root,root,-)
89 %doc AUTHORS ChangeLog COPYING NEWS README TODO
90 %{_libdir}/pidgin/libsipe.so
91 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
94 %changelog
95 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
96 - update to 1.6.3
98 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
99 - reduce libpurple-devel requirement to >= 2.3.1
101 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
102 - update to 1.6.2
104 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
105 - reduce libpurple-devel requirement to >= 2.4.1
107 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
108 - com_err.h only required for kerberos
110 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
111 - require libpurple-devel >= 2.5.0
113 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
114 - refactor configure parameters
115 - make kerberos configurable
116 - don't hard code prefix for git builds
118 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
119 - removed unnecessary zlib-devel
121 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
122 - fix prefix for git builds
124 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
125 - append -Wno-unused-parameter for GCC <4.4 compilation errors
127 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
128 - remove duplicate GPL2
130 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
131 - use "--with git" to build from git
132 - corrected download URL for release archive
133 - add missing BR gettext-devel
135 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
136 - use default rpmbuild CFLAGS also for git builds
137 - merge with SPEC files created by mricon & jberanek
139 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
140 - initial RPM SPEC example generated