contrib: improve error messages in D-Bus scripts
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob84bd1d2cbe84f46e26c71b6f4abde793a1139c18
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20160405git4fedafa
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.22.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: http://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
43 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
44 BuildRequires: pkgconfig(libxml-2.0)
45 BuildRequires: pkgconfig(nss)
46 BuildRequires: pkgconfig(purple) >= 2.4.0
47 %if 0%{?_with_git:1}
48 BuildRequires: autoconf
49 BuildRequires: automake
50 %endif
51 BuildRequires: gettext
52 BuildRequires: intltool
53 BuildRequires: libtool
54 # Use "--without vv" to disable Voice & Video features
55 %if !0%{?_without_vv:1}
56 BuildRequires: pkgconfig(purple) >= 2.8.0
57 BuildRequires: pkgconfig(farstream-0.2)
58 BuildRequires: pkgconfig(gio-2.0)
59 BuildRequires: pkgconfig(nice) >= 0.1.0
60 %if 0%{?fedora} >= 22
61 BuildRequires: pkgconfig(gstreamer-1.0)
62 %else
63 %if 0%{?fedora} >= 20
64 # Dependency required when gstreamer support is split into two packages
65 %define requires_libnice_gstreamer 1
66 %endif
67 BuildRequires: pkgconfig(gstreamer-0.10)
68 %endif
69 %endif
70 # Use "--without telepathy" to disable telepathy
71 %if !0%{?_without_telepathy:1}
72 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
73 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
74 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
75 BuildRequires: pkgconfig(gobject-2.0)
76 BuildRequires: pkgconfig(dbus-glib-1)
77 BuildRequires: gmime-devel
78 %endif
80 # Configurable components
81 # Use "--without kerberos" to disable krb5
82 %if !0%{?_without_kerberos:1}
83 BuildRequires: krb5-devel
84 %if 0%{?fedora} >= 21
85 BuildRequires: gssntlmssp-devel >= 0.5.0
86 %define requires_gssntlmssp 1
87 %endif
88 %endif
90 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
93 %description
94 A third-party plugin for the Pidgin multi-protocol instant messenger.
95 It implements the extended version of SIP/SIMPLE used by various products:
97 * Skype for Business
98 * Microsoft Office 365
99 * Microsoft Business Productivity Online Suite (BPOS)
100 * Microsoft Lync Server
101 * Microsoft Office Communications Server (OCS 2007/2007 R2)
102 * Microsoft Live Communications Server (LCS 2003/2005)
104 With this plugin you should be able to replace your Microsoft Office
105 Communicator client with Pidgin.
107 This package provides the icon set for Pidgin.
110 %package -n %{purple_plugin}
111 Summary: Libpurple protocol plugin to connect to MS Office Communicator
112 Group: %{pkg_group}
113 License: GPLv2+
114 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
116 %if 0%{?requires_libnice_gstreamer}
117 Requires: libnice-gstreamer
118 %endif
119 %if 0%{?requires_gssntlmssp}
120 Requires: gssntlmssp >= 0.5.0
121 %endif
123 %description -n %{purple_plugin}
124 A third-party plugin for the Pidgin multi-protocol instant messenger.
125 It implements the extended version of SIP/SIMPLE used by various products:
127 * Skype for Business
128 * Microsoft Office 365
129 * Microsoft Business Productivity Online Suite (BPOS)
130 * Microsoft Lync Server
131 * Microsoft Office Communications Server (OCS 2007/2007 R2)
132 * Microsoft Live Communications Server (LCS 2003/2005)
134 This package provides the protocol plugin for libpurple clients.
137 %if !0%{?_without_telepathy:1}
138 %package -n %{empathy_files}
139 Summary: Telepathy connection manager to connect to MS Office Communicator
140 Group: %{pkg_group}
141 License: GPLv2+
142 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
144 %description -n %{empathy_files}
145 A Telepathy connection manager that implements the extended version of
146 SIP/SIMPLE used by various products:
148 * Skype for Business
149 * Microsoft Office 365
150 * Microsoft Business Productivity Online Suite (BPOS)
151 * Microsoft Lync Server
152 * Microsoft Office Communications Server (OCS 2007/2007 R2)
153 * Microsoft Live Communications Server (LCS 2003/2005)
155 This package provides the icon set for Empathy.
158 %package -n %{ktp_files}
159 Summary: Telepathy connection manager to connect to MS Office Communicator
160 Group: %{pkg_group}
161 License: GPLv2+
162 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
164 %description -n %{ktp_files}
165 A Telepathy connection manager that implements the extended version of
166 SIP/SIMPLE used by various products:
168 * Skype for Business
169 * Microsoft Office 365
170 * Microsoft Business Productivity Online Suite (BPOS)
171 * Microsoft Lync Server
172 * Microsoft Office Communications Server (OCS 2007/2007 R2)
173 * Microsoft Live Communications Server (LCS 2003/2005)
175 This package provides the profile for KTP account manager.
178 %package -n %{telepathy_plugin}
179 Summary: Telepathy connection manager to connect to MS Office Communicator
180 Group: %{pkg_group}
181 License: GPLv2+
182 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
184 %if 0%{?requires_libnice_gstreamer}
185 # @TODO: remove comment when telepathy plugin supports Voice & Video features
186 #Requires: libnice-gstreamer
187 %endif
188 %if 0%{?requires_gssntlmssp}
189 Requires: gssntlmssp >= 0.5.0
190 %endif
192 %description -n %{telepathy_plugin}
193 A Telepathy connection manager that implements the extended version of
194 SIP/SIMPLE used by various products:
196 * Skype for Business
197 * Microsoft Office 365
198 * Microsoft Business Productivity Online Suite (BPOS)
199 * Microsoft Lync Server
200 * Microsoft Office Communications Server (OCS 2007/2007 R2)
201 * Microsoft Live Communications Server (LCS 2003/2005)
203 This package provides the protocol support for Telepathy clients.
204 %endif
207 %package -n %{common_files}
208 Summary: Common files for SIPE protocol plugins
209 Group: %{pkg_group}
210 License: GPLv2+
211 BuildArch: noarch
213 %description -n %{common_files}
214 This package provides common files for the SIPE protocol plugins:
216 * Localisation
219 %prep
220 %if 0%{?_with_git:1}
221 %setup -q -n %{name}-%{git}
222 %else
223 %setup -q
224 %endif
227 %build
228 %if 0%{?_with_git:1}
229 ./autogen.sh
230 %endif
231 %configure \
232 %if 0%{?_without_vv:1}
233 --without-vv \
234 %endif
235 %if !0%{?_without_kerberos:1}
236 --with-krb5 \
237 %endif
238 --enable-purple \
239 %if !0%{?_without_telepathy:1}
240 --enable-telepathy
241 %else
242 --disable-telepathy
243 %endif
244 make %{?_smp_mflags}
245 make %{?_smp_mflags} check
248 %install
249 %makeinstall
250 find %{buildroot} -type f -name "*.la" -delete -print
251 # Pidgin doesn't have 24 or 32 pixel icons
252 rm -f \
253 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
254 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
255 %find_lang %{name}
258 %clean
259 rm -rf %{buildroot}
262 %files -n %{purple_plugin}
263 %defattr(-,root,root,-)
264 %doc AUTHORS ChangeLog COPYING NEWS README TODO
265 %{_libdir}/purple-2/libsipe.so
268 %if !0%{?_without_telepathy:1}
269 %files -n %{empathy_files}
270 %defattr(-,root,root,-)
271 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
272 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
275 %files -n %{ktp_files}
276 %defattr(-,root,root,-)
277 %doc AUTHORS COPYING
278 %{_datadir}/telepathy/profiles/sipe.profile
281 %files -n %{telepathy_plugin}
282 %defattr(-,root,root,-)
283 %doc AUTHORS ChangeLog COPYING NEWS README TODO
284 %{_datadir}/dbus-1/services/*.sipe.service
285 %{_libexecdir}/telepathy-sipe
286 %endif
289 %files -n %{common_files} -f %{name}.lang
290 %defattr(-,root,root,-)
293 %files
294 %defattr(-,root,root,-)
295 %{_datadir}/appdata/%{name}.metainfo.xml
296 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
297 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
300 %changelog
301 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
302 - update to 1.22.1
304 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
305 - update to 1.22.0
307 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
308 - add BR gio-2.0
310 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
311 - add BR farstream-0.2
313 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
314 - update to 1.21.1
316 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
317 - update to 1.21.0
319 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
320 - align with Fedora SPEC file
322 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
323 - add AppStream metadata file
325 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
326 - add dependency on pkgconfig(gstreamer-1.0) for F22+
328 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
329 - update to 1.20.1
331 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
332 - we also support "Skype for Business"
334 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
335 - update to 1.20.0
337 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
338 - update to 1.19.1
340 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
341 - update to 1.19.0
343 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
344 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
345 - enable Voice & Video features by default
346 - move dependency on libnice-gstreamer to correct packages
348 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
349 - update to 1.18.5
351 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
352 - update to 1.18.4
354 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
355 - update to 1.18.3
357 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
358 - update to 1.18.2
360 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
361 - update to 1.18.1
363 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
364 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
366 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
367 - F20+ require libnice-gstreamer for correct operation
369 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
370 - update to 1.18.0
372 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
373 - update to 1.17.3
375 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
376 - update to 1.17.2
378 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
379 - update to 1.17.1
381 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
382 - update to 1.17.0
384 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
385 - update to 1.16.1
387 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
388 - update to 1.16.0
390 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
391 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
393 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
394 - update to 1.15.1
396 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
397 - update package description texts
399 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
400 - update to 1.15.0
402 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
403 - update to 1.14.1
405 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
406 - update to 1.14.0
408 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
409 - BR telepathy-glib-devel >= 0.18.0
411 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
412 - BR telepathy-glib-devel >= 0.14.0
414 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
415 - add ktp-accounts-kcm-sipe package
417 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
418 - telepathy now requires glib-2.0 >= 2.22.0
419 - use "--without telepathy" to disable telepathy packages
421 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
422 - add empathy-sipe package
424 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
425 - add telepathy-sipe & sipe-common packages
427 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
428 - update to 1.13.3
430 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
431 - update to 1.13.2
433 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
434 - update to 1.13.1
436 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
437 - update to 1.13.0
439 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
440 - we do support Microsoft Lync Server 2010 now.
442 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
443 - update GPL2 license name
445 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
446 - add BR gmime-devel
448 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
449 - add BR nss-devel
451 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
452 - update to 1.12.0
454 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
455 - add "--with vv" option to enable Voice & Video features
457 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
458 - update to 1.11.2
460 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
461 - update to 1.11.1
463 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
464 - update to 1.11.0
466 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
467 - add (commented out) BR libnice-devel
469 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
470 - update to 1.10.1
472 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
473 - add (commented out) BR nss-devel
475 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
476 - update to 1.10.0
478 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
479 - changed --with/--without options to --enable/--disable
481 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
482 - removed --with-krb5 configure option as it is autodetected now
484 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
485 - add SVG icon
487 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
488 - add BR glib2-devel >= 2.12.0
490 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
491 - add tests to build
493 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
494 - update to 1.9.1
496 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
497 - add BR libxml2-devel
499 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
500 - update to 1.9.0
502 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
503 - increased libpurple build requisite to >= 2.4.0
505 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
506 - sync with RPM SPEC from contrib/OBS
508 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
509 - update package summary & description
511 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
512 - update to 1.8.1
514 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
515 - update to 1.8.0
517 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
518 - autogen.sh no longer runs configure
520 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
521 - add configure parameters for purple and telepathy
523 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
524 - add Epoch: for git packages to avoid update clash with official packages
526 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
527 - update to 1.7.1
529 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
530 - add missing Group: to purple-sipe
532 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
533 - update to 1.7.0
535 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
536 - move non-Pidgin files to new sub-package purple-sipe
538 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
539 - remove directory for emoticon theme icons
541 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
542 - libpurple protocol plugins are located under %%{_libdir}/purple-2
544 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
545 - added directory for emoticon theme icons
547 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
548 - update to 1.6.3
550 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
551 - reduce libpurple-devel requirement to >= 2.3.1
553 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
554 - update to 1.6.2
556 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
557 - reduce libpurple-devel requirement to >= 2.4.1
559 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
560 - com_err.h only required for kerberos
562 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
563 - require libpurple-devel >= 2.5.0
565 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
566 - refactor configure parameters
567 - make kerberos configurable
568 - don't hard code prefix for git builds
570 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
571 - removed unnecessary zlib-devel
573 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
574 - fix prefix for git builds
576 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
577 - append -Wno-unused-parameter for GCC <4.4 compilation errors
579 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
580 - remove duplicate GPL2
582 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
583 - use "--with git" to build from git
584 - corrected download URL for release archive
585 - add missing BR gettext-devel
587 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
588 - use default rpmbuild CFLAGS also for git builds
589 - merge with SPEC files created by mricon & jberanek
591 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
592 - initial RPM SPEC example generated