utils: improve message debug in safe mode
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob189e7c1064da6a4e63d4e086210db16a83e51dfe
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20171022gitfe34eaec
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.23.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: http://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(dbus-1)
43 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
44 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(nss)
47 BuildRequires: pkgconfig(purple) >= 2.7.0
48 %if 0%{?_with_git:1}
49 BuildRequires: autoconf
50 BuildRequires: automake
51 %endif
52 BuildRequires: appstream
53 BuildRequires: gettext
54 BuildRequires: intltool
55 BuildRequires: libtool
56 # Use "--without vv" to disable Voice & Video features
57 %if !0%{?_without_vv:1}
58 BuildRequires: pkgconfig(purple) >= 2.8.0
59 BuildRequires: pkgconfig(farstream-0.2)
60 BuildRequires: pkgconfig(gio-2.0)
61 BuildRequires: pkgconfig(gstreamer-1.0)
62 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
63 BuildRequires: pkgconfig(nice) >= 0.1.0
64 %endif
65 # Use "--without telepathy" to disable telepathy
66 %if !0%{?_without_telepathy:1}
67 BuildRequires: gmime-devel
68 BuildRequires: pkgconfig(dbus-glib-1)
69 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
70 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
71 BuildRequires: pkgconfig(gobject-2.0)
72 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
73 %endif
75 # Configurable components
76 # Use "--without kerberos" to disable krb5
77 %if !0%{?_without_kerberos:1}
78 BuildRequires: pkgconfig(krb5)
79 %if 0%{?fedora} || 0%{?rhel} >= 7
80 BuildRequires: gssntlmssp-devel >= 0.5.0
81 %define requires_gssntlmssp 1
82 %endif
83 %endif
85 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
88 %description
89 A third-party plugin for the Pidgin multi-protocol instant messenger.
90 It implements the extended version of SIP/SIMPLE used by various products:
92 * Skype for Business
93 * Microsoft Office 365
94 * Microsoft Business Productivity Online Suite (BPOS)
95 * Microsoft Lync Server
96 * Microsoft Office Communications Server (OCS 2007/2007 R2)
97 * Microsoft Live Communications Server (LCS 2003/2005)
99 With this plugin you should be able to replace your Microsoft Office
100 Communicator client with Pidgin.
102 This package provides the icon set for Pidgin.
105 %package -n %{purple_plugin}
106 Summary: Libpurple protocol plugin to connect to MS Office Communicator
107 Group: %{pkg_group}
108 License: GPLv2+
109 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
111 %if 0%{?requires_gssntlmssp}
112 Requires: gssntlmssp >= 0.5.0
113 %endif
115 %description -n %{purple_plugin}
116 A third-party plugin for the Pidgin multi-protocol instant messenger.
117 It implements the extended version of SIP/SIMPLE used by various products:
119 * Skype for Business
120 * Microsoft Office 365
121 * Microsoft Business Productivity Online Suite (BPOS)
122 * Microsoft Lync Server
123 * Microsoft Office Communications Server (OCS 2007/2007 R2)
124 * Microsoft Live Communications Server (LCS 2003/2005)
126 This package provides the protocol plugin for libpurple clients.
129 %if !0%{?_without_telepathy:1}
130 %package -n %{empathy_files}
131 Summary: Telepathy connection manager to connect to MS Office Communicator
132 Group: %{pkg_group}
133 License: GPLv2+
134 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
136 %description -n %{empathy_files}
137 A Telepathy connection manager that implements the extended version of
138 SIP/SIMPLE used by various products:
140 * Skype for Business
141 * Microsoft Office 365
142 * Microsoft Business Productivity Online Suite (BPOS)
143 * Microsoft Lync Server
144 * Microsoft Office Communications Server (OCS 2007/2007 R2)
145 * Microsoft Live Communications Server (LCS 2003/2005)
147 This package provides the icon set for Empathy.
150 %package -n %{ktp_files}
151 Summary: Telepathy connection manager to connect to MS Office Communicator
152 Group: %{pkg_group}
153 License: GPLv2+
154 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
156 %description -n %{ktp_files}
157 A Telepathy connection manager that implements the extended version of
158 SIP/SIMPLE used by various products:
160 * Skype for Business
161 * Microsoft Office 365
162 * Microsoft Business Productivity Online Suite (BPOS)
163 * Microsoft Lync Server
164 * Microsoft Office Communications Server (OCS 2007/2007 R2)
165 * Microsoft Live Communications Server (LCS 2003/2005)
167 This package provides the profile for KTP account manager.
170 %package -n %{telepathy_plugin}
171 Summary: Telepathy connection manager to connect to MS Office Communicator
172 Group: %{pkg_group}
173 License: GPLv2+
174 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
176 %if 0%{?requires_gssntlmssp}
177 Requires: gssntlmssp >= 0.5.0
178 %endif
180 %description -n %{telepathy_plugin}
181 A Telepathy connection manager that implements the extended version of
182 SIP/SIMPLE used by various products:
184 * Skype for Business
185 * Microsoft Office 365
186 * Microsoft Business Productivity Online Suite (BPOS)
187 * Microsoft Lync Server
188 * Microsoft Office Communications Server (OCS 2007/2007 R2)
189 * Microsoft Live Communications Server (LCS 2003/2005)
191 This package provides the protocol support for Telepathy clients.
192 %endif
195 %package -n %{common_files}
196 Summary: Common files for SIPE protocol plugins
197 Group: %{pkg_group}
198 License: GPLv2+
199 BuildArch: noarch
201 %description -n %{common_files}
202 This package provides common files for the SIPE protocol plugins:
204 * Localisation
207 %prep
208 %if 0%{?_with_git:1}
209 %setup -q -n %{name}-%{git}
210 %else
211 %setup -q
212 %endif
215 %build
216 %if 0%{?_with_git:1}
217 ./autogen.sh
218 %endif
219 %configure \
220 %if 0%{?_without_vv:1}
221 --without-vv \
222 %endif
223 %if !0%{?_without_kerberos:1}
224 --with-krb5 \
225 %endif
226 --enable-purple \
227 %if !0%{?_without_telepathy:1}
228 --enable-telepathy
229 %else
230 --disable-telepathy
231 %endif
232 make %{?_smp_mflags}
235 %install
236 %make_install
237 find %{buildroot} -type f -name "*.la" -delete -print
238 # Pidgin doesn't have 24 or 32 pixel icons
239 rm -f \
240 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
241 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
242 %find_lang %{name}
245 %check
246 make %{?_smp_mflags} check
249 %clean
250 rm -rf %{buildroot}
253 %files -n %{purple_plugin}
254 %defattr(-,root,root,-)
255 %doc AUTHORS ChangeLog COPYING NEWS README TODO
256 %{_libdir}/purple-2/libsipe.so
259 %if !0%{?_without_telepathy:1}
260 %files -n %{empathy_files}
261 %defattr(-,root,root,-)
262 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
263 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
266 %files -n %{ktp_files}
267 %defattr(-,root,root,-)
268 %doc AUTHORS COPYING
269 %{_datadir}/telepathy/profiles/sipe.profile
272 %files -n %{telepathy_plugin}
273 %defattr(-,root,root,-)
274 %doc AUTHORS ChangeLog COPYING NEWS README TODO
275 %{_datadir}/dbus-1/services/*.sipe.service
276 %{_libexecdir}/telepathy-sipe
277 %endif
280 %files -n %{common_files} -f %{name}.lang
281 %defattr(-,root,root,-)
284 %files
285 %defattr(-,root,root,-)
286 %{_datadir}/metainfo/%{name}.metainfo.xml
287 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
288 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
291 %changelog
292 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
293 - add BR appstream
295 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
296 - add support for new AppStream metadata file location
298 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
299 - update to 1.23.0
300 - raise BR glib-2.0 >= 2.18.0
301 - raise BR purple >= 2.7.0
303 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
304 - add BR dbus-1
306 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
307 - update to 1.22.1
309 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
310 - update to 1.22.0
312 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
313 - add BR gio-2.0
315 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
316 - add BR farstream-0.2
318 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
319 - update to 1.21.1
321 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
322 - update to 1.21.0
324 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
325 - align with Fedora SPEC file
327 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
328 - add AppStream metadata file
330 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
331 - add dependency on pkgconfig(gstreamer-1.0) for F22+
333 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
334 - update to 1.20.1
336 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
337 - we also support "Skype for Business"
339 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
340 - update to 1.20.0
342 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
343 - update to 1.19.1
345 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
346 - update to 1.19.0
348 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
349 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
350 - enable Voice & Video features by default
351 - move dependency on libnice-gstreamer to correct packages
353 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
354 - update to 1.18.5
356 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
357 - update to 1.18.4
359 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
360 - update to 1.18.3
362 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
363 - update to 1.18.2
365 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
366 - update to 1.18.1
368 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
369 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
371 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
372 - F20+ require libnice-gstreamer for correct operation
374 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
375 - update to 1.18.0
377 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
378 - update to 1.17.3
380 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
381 - update to 1.17.2
383 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
384 - update to 1.17.1
386 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
387 - update to 1.17.0
389 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
390 - update to 1.16.1
392 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
393 - update to 1.16.0
395 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
396 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
398 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
399 - update to 1.15.1
401 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
402 - update package description texts
404 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
405 - update to 1.15.0
407 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
408 - update to 1.14.1
410 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
411 - update to 1.14.0
413 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
414 - BR telepathy-glib-devel >= 0.18.0
416 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
417 - BR telepathy-glib-devel >= 0.14.0
419 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
420 - add ktp-accounts-kcm-sipe package
422 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
423 - telepathy now requires glib-2.0 >= 2.22.0
424 - use "--without telepathy" to disable telepathy packages
426 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
427 - add empathy-sipe package
429 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
430 - add telepathy-sipe & sipe-common packages
432 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
433 - update to 1.13.3
435 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
436 - update to 1.13.2
438 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
439 - update to 1.13.1
441 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
442 - update to 1.13.0
444 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
445 - we do support Microsoft Lync Server 2010 now.
447 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
448 - update GPL2 license name
450 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
451 - add BR gmime-devel
453 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
454 - add BR nss-devel
456 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
457 - update to 1.12.0
459 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
460 - add "--with vv" option to enable Voice & Video features
462 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
463 - update to 1.11.2
465 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
466 - update to 1.11.1
468 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
469 - update to 1.11.0
471 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
472 - add (commented out) BR libnice-devel
474 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
475 - update to 1.10.1
477 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
478 - add (commented out) BR nss-devel
480 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
481 - update to 1.10.0
483 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
484 - changed --with/--without options to --enable/--disable
486 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
487 - removed --with-krb5 configure option as it is autodetected now
489 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
490 - add SVG icon
492 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
493 - add BR glib2-devel >= 2.12.0
495 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
496 - add tests to build
498 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
499 - update to 1.9.1
501 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
502 - add BR libxml2-devel
504 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
505 - update to 1.9.0
507 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
508 - increased libpurple build requisite to >= 2.4.0
510 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
511 - sync with RPM SPEC from contrib/OBS
513 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
514 - update package summary & description
516 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
517 - update to 1.8.1
519 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
520 - update to 1.8.0
522 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
523 - autogen.sh no longer runs configure
525 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
526 - add configure parameters for purple and telepathy
528 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
529 - add Epoch: for git packages to avoid update clash with official packages
531 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
532 - update to 1.7.1
534 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
535 - add missing Group: to purple-sipe
537 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
538 - update to 1.7.0
540 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
541 - move non-Pidgin files to new sub-package purple-sipe
543 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
544 - remove directory for emoticon theme icons
546 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
547 - libpurple protocol plugins are located under %%{_libdir}/purple-2
549 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
550 - added directory for emoticon theme icons
552 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
553 - update to 1.6.3
555 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
556 - reduce libpurple-devel requirement to >= 2.3.1
558 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
559 - update to 1.6.2
561 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
562 - reduce libpurple-devel requirement to >= 2.4.1
564 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
565 - com_err.h only required for kerberos
567 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
568 - require libpurple-devel >= 2.5.0
570 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
571 - refactor configure parameters
572 - make kerberos configurable
573 - don't hard code prefix for git builds
575 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
576 - removed unnecessary zlib-devel
578 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
579 - fix prefix for git builds
581 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
582 - append -Wno-unused-parameter for GCC <4.4 compilation errors
584 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
585 - remove duplicate GPL2
587 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
588 - use "--with git" to build from git
589 - corrected download URL for release archive
590 - add missing BR gettext-devel
592 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
593 - use default rpmbuild CFLAGS also for git builds
594 - merge with SPEC files created by mricon & jberanek
596 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
597 - initial RPM SPEC example generated