Disable the vnc CopyRect encoding
[qemu-kvm/fedora.git] / kvm / kernel / kvm-kmod.spec
blob89b3d882c001142af06dc227eadb6f8620db7090
1 %define kmod_name kvm
3 Name: kvm-kmod
4 Version: 0.0
5 Release: 0
6 Summary: %{kmod_name} kernel module
8 Group: System Environment/Kernel
9 License: GPL
10 URL: http://www.qumranet.com
11 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
13 ExclusiveArch: i386 x86_64 ia64
15 %description
16 This kernel module provides support for virtual machines using hardware support
17 (Intel VT-x&VT-i or AMD SVM).
19 %prep
21 %build
23 rm -rf %{buildroot}
25 %install
27 %define kverrel unknown
28 %define moddir /lib/modules/%{kverrel}/extra
29 mkdir -p %{buildroot}/%{moddir}
30 cp %{objdir}/%{kmod_name}.ko %{objdir}/%{kmod_name}-*.ko %{buildroot}/%{moddir}
31 chmod u+x %{buildroot}/%{moddir}/%{kmod_name}*.ko
33 %post
35 depmod %{kverrel}
37 %postun
39 depmod %{kverrel}
41 %clean
42 %{__rm} -rf %{buildroot}
44 %files
45 %{moddir}/%{kmod_name}.ko
46 %ifarch i386 x86_64
47 %{moddir}/%{kmod_name}-amd.ko
48 %endif
49 %{moddir}/%{kmod_name}-intel.ko
52 %changelog