Use python2.5 in Maemo packaging
[panucci.git] / debian / rules
blob8719994faa032f6c49ec6edecf90e7345e1407ce
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 CHANGELOG = debian/changelog
13 DOCS = #AUTHORS README
15 PYTHON = /usr/bin/python2.5
16 SETUP = ${PYTHON} setup.py
18 DEBPACKAGE = panucci
19 DESTDIR = debian/${DEBPACKAGE}
20 PREFIX = usr
22 configure:
23 true
25 build: build-stamp
26 build-stamp:
27 dh_testdir
28 make mo
29 make data/panucci.service
30 ${SETUP} build
31 touch build-stamp
33 clean:
34 dh_testdir
35 dh_testroot
36 rm -f build-stamp
37 ${SETUP} clean --all
38 rm -rf build dist
39 dh_clean
40 make clean
42 install: build
43 dh_testdir
44 dh_testroot
45 dh_clean -k
46 dh_installdirs
47 ${SETUP} install --no-compile -O2 --root='$(DESTDIR)' --prefix='$(PREFIX)' --install-lib /opt/panucci/lib
48 mv $(DESTDIR)/$(PREFIX)/share/panucci/* $(DESTDIR)//opt/panucci/
49 rm -rf $(DESTDIR)/$(PREFIX)/share/panucci
51 binary-arch:
53 binary-indep: build install
54 dh_testdir
55 dh_testroot
56 dh_installchangelogs $(CHANGELOG)
57 dh_installdocs $(DOCS)
58 dh_installmenu
59 dh_installman
60 dh_compress
61 dh_fixperms
62 dh_python
63 dh_installdeb
64 dh_gencontrol
65 dh_md5sums
66 dh_builddeb
68 binary: binary-indep
70 .PHONY: build clean binary-indep binary-arch binary install configure