Use playbin2 instead of the old playbin
[panucci.git] / debian / rules
blob746520d03744cd6294a7bf304dc8a1b0b55b9211
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 CHANGELOG = debian/changelog
13 DOCS = #AUTHORS README
15 PYTHON = /usr/bin/python2.5
16 SETUP = ${PYTHON} setup.py
18 DEBPACKAGE = panucci
19 DESTDIR = debian/${DEBPACKAGE}
20 PREFIX = usr
22 configure: configure-stamp
23 configure-stamp:
24 dh_testdir
25 # Add here commands to configure the package.
26 touch configure-stamp
28 build: build-stamp
29 build-stamp: configure-stamp
30 dh_testdir
31 ${SETUP} build
32 touch build-stamp
34 clean:
35 dh_testdir
36 dh_testroot
37 rm -f build-stamp configure-stamp
38 ${SETUP} clean --all
39 rm -rf build dist
40 dh_clean
41 make clean
43 install: build
44 dh_testdir
45 dh_testroot
46 dh_clean -k
47 dh_installdirs
48 PREFIX=$(PREFIX) DESTDIR=$(DESTDIR) $(MAKE) gen_gettext dbus-service-install copy-schemas
49 ${SETUP} install --no-compile -O2 --root='$(DESTDIR)' --prefix='$(PREFIX)'
51 binary-arch:
53 binary-indep: build install
54 dh_testdir
55 dh_testroot
56 dh_installchangelogs $(CHANGELOG)
57 dh_installdocs $(DOCS)
58 dh_installmenu
59 dh_installman
60 dh_compress
61 dh_fixperms
62 dh_python
63 dh_installdeb
64 dh_gencontrol
65 dh_md5sums
66 dh_builddeb
68 binary: binary-indep
70 .PHONY: build clean binary-indep binary-arch binary install configure