matrix-gui-e: bump PR for init file fixes
[openembedded.git] / recipes / powervr-drivers / bc-cube_0.1.0.bb
blob6323a79a5f2a3d3484a0b3bd318804f48ac6c671
1 DESCRIPTION = "TI Texture streaming using bufferclass API demo (spinning video cube)"
2 LICENSE = "TI-BSD/GPLv2"
3 DEPENDS = "virtual/egl"
5 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/OMAP35x_AM35x_Video_Texture_Streaming/1_0/exports/bc-cat-${PV}.tar.gz \
6 file://bc-cat-0.1.0-BC_PIX_FMT_.patch;striplevel=0"
8 S = "${WORKDIR}/bc-cat-${PV}"
10 CFLAGS += " -DLINUX -I../include -I${STAGING_INCDIR}/services4/3rdparty/bufferclass_ti/ -I${STAGING_INCDIR}/include4"
11 LDFLAGS += "-lGLES_CM -lEGL"
13 do_configure() {
14 cd test
15 sed -i -e s:pixel_fmt:fourcc:g *.c
18 # build both fb and x11 version
19 do_compile() {
20 cd test
21 oe_runmake -e clean
22 oe_runmake -e
23 mv gles1_bc_mmap gles1_bc_mmap-fb
24 mv gles1_bc_webcam gles1_bc_webcam-fb
26 oe_runmake -e clean
27 CFLAGS="${CFLAGS} -DX11" oe_runmake -e X11BUILD=1
28 mv gles1_bc_mmap gles1_bc_mmap-x11
29 mv gles1_bc_webcam gles1_bc_webcam-x11
33 do_install() {
34 install -d ${D}${bindir}
35 install -m 0755 ${S}/test/gles1_bc_mmap-* ${D}${bindir}
36 install -m 0755 ${S}/test/gles1_bc_webcam-* ${D}${bindir}
39 PACKAGES =+ "${PN}-fb ${PN}-x11"
40 FILES_${PN}-x11 = "${bindir}/*x11"
41 FILES_${PN}-fb = "${bindir}/*fb"