cornucopia: bump SRCREV
[openembedded.git] / recipes / powervr-drivers / bc-cube_0.1.0.bb
blob62dfc5b590a9de4e1817660e8d9fce85cb9d0da1
1 DESCRIPTION = "TI Texture streaming using bufferclass API demo (spinning video cube)"
2 LICENSE = "TI-BSD/GPLv2"
3 DEPENDS = "virtual/egl"
4 require recipes/egl/egl.inc
6 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/apps_processors/OMAP35x_AM35x_Video_Texture_Streaming/1_0/exports/bc-cat-${PV}.tar.gz \
7 file://bc-cat-0.1.0-BC_PIX_FMT_.patch;striplevel=0"
9 S = "${WORKDIR}/bc-cat-${PV}"
11 CFLAGS += " -DLINUX -I../include -I${STAGING_INCDIR}/services4/3rdparty/bufferclass_ti/ -I${STAGING_INCDIR}/include4"
12 LDFLAGS += "-lGLES_CM -lEGL"
14 do_configure() {
15 cd test
16 sed -i -e s:pixel_fmt:fourcc:g *.c
19 # build both fb and x11 version
20 do_compile() {
21 cd test
22 oe_runmake -e clean
23 oe_runmake -e
24 mv gles1_bc_mmap gles1_bc_mmap-fb
25 mv gles1_bc_webcam gles1_bc_webcam-fb
27 oe_runmake -e clean
28 CFLAGS="${CFLAGS} -DX11" oe_runmake -e X11BUILD=1
29 mv gles1_bc_mmap gles1_bc_mmap-x11
30 mv gles1_bc_webcam gles1_bc_webcam-x11
34 do_install() {
35 install -d ${D}${bindir}
36 install -m 0755 ${S}/test/gles1_bc_mmap-* ${D}${bindir}
37 install -m 0755 ${S}/test/gles1_bc_webcam-* ${D}${bindir}
40 PACKAGES =+ "${PN}-fb ${PN}-x11"
41 FILES_${PN}-x11 = "${bindir}/*x11"
42 FILES_${PN}-fb = "${bindir}/*fb"