angstrom mirrors: fix regression introduced by http://cgit.openembedded.org/cgit...
[openembedded.git] / recipes / cnc / openredalert_r438.bb
blob4723822685e30bf8c69c38555a47b37699ffecb9
1 DESCRIPTION = "Game engine to run Red Alert 1"
2 LICENSE = "GPLv2"
4 DEPENDS = "virtual/libsdl libsdl-mixer"
6 SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
7 file://gcc43-fix.patch;patch=1 \
8 file://openredalert-launcher"
10 PR = "r1"
12 S = "${WORKDIR}"
14 CFLAGS_append = " -I. -I${STAGING_INCDIR}"
16 do_compile() {
17 cd ${S}/src ; cp ${S}/makefile .
18 oe_runmake -e
21 do_install() {
22 install -d ${D}/${datadir}/games/redalert/
23 cp -pPr ${S}/data ${D}/${datadir}/games/redalert/
24 install -m 0755 ${S}/src/openredalert ${D}/${datadir}/games/redalert/
26 install -d ${D}/${bindir}
27 install -m 0755 ${S}/openredalert-launcher ${D}/${bindir}
30 FILES_${PN} += "${datadir}/games/redalert/"
31 FILES_${PN}-dbg += "${datadir}/games/redalert/.debug"
33 SRC_URI[md5sum] = "12dc7a8042c023bc77b7830946fc8492"
34 SRC_URI[sha256sum] = "68058b6ffd9a286111c1860ca6d53af0d98d3f0c2a53875efd72ab381a3f9d6d"