cornucopia: bump SRCREV
[openembedded.git] / recipes / cnc / openredalert_r438.bb
blob2d1b93146ddd8a8e9f147901533f4cb473cbbd13
1 DESCRIPTION = "Game engine to run Red Alert 1"
2 LICENSE = "GPLv2"
4 DEPENDS = "virtual/libsdl libsdl-mixer"
6 SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz;subdir=${BPN}-${PV} \
7 file://gcc43-fix.patch \
8 file://openredalert-launcher"
10 PR = "r1"
12 CFLAGS_append = " -I. -I${STAGING_INCDIR}"
14 do_compile() {
15 cd ${S}/src ; cp ${S}/makefile .
16 oe_runmake -e
19 do_install() {
20 install -d ${D}/${datadir}/games/redalert/
21 cp -pPr ${S}/data ${D}/${datadir}/games/redalert/
22 install -m 0755 ${S}/src/openredalert ${D}/${datadir}/games/redalert/
24 install -d ${D}/${bindir}
25 install -m 0755 ${WORKDIR}/openredalert-launcher ${D}/${bindir}
28 FILES_${PN} += "${datadir}/games/redalert/"
29 FILES_${PN}-dbg += "${datadir}/games/redalert/.debug"
31 SRC_URI[md5sum] = "12dc7a8042c023bc77b7830946fc8492"
32 SRC_URI[sha256sum] = "68058b6ffd9a286111c1860ca6d53af0d98d3f0c2a53875efd72ab381a3f9d6d"