NASM 0.98
[nasm.git] / nasm.spec
blobc5475134378f1824a484cf75dd4b986105c084c3
1 Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
2 Name: nasm
3 Version: 0.98
4 Release: 1
5 Copyright: Freely Distributable
6 Group: Development/Languages
7 Source: ftp://ftp.us.kernel.org/pub/software/devel/nasm/source/nasm-%{version}.tar.gz
8 URL: http://www.cryogen.com/Nasm/
9 BuildRoot: /tmp/rpm-build-nasm
10 Prefix: /usr
12 %package doc
13 Summary: Extensive documentation for NASM
14 Group: Development/Languages
15 Prereq: /sbin/install-info
17 %package rdoff
18 Summary: Tools for the RDOFF binary format, sometimes used with NASM.
19 Group: Development/Tools
21 %description
22 NASM is the Netwide Assembler, a free portable assembler for the Intel
23 80x86 microprocessor series, using primarily the traditional Intel
24 instruction mnemonics and syntax.
26 %description doc
27 Extensive documentation for the Netwide Assembler, NASM, in HTML,
28 info, PostScript and text formats.
30 %description rdoff
31 Tools for the operating-system independent RDOFF binary format, which
32 is sometimes used with the Netwide Assembler (NASM). These tools
33 include linker, library manager, loader, and information dump.
35 %prep
36 %setup
38 %build
39 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=-s ./configure --prefix=/usr
40 make everything
42 %install
43 mkdir -p "$RPM_BUILD_ROOT"
44 mkdir -p "$RPM_BUILD_ROOT"/usr/bin
45 mkdir -p "$RPM_BUILD_ROOT"/usr/man/man1
46 mkdir -p "$RPM_BUILD_ROOT"/usr/info
47 DOC="$RPM_BUILD_ROOT"/usr/doc/nasm-%{version}
48 rm -rf "$DOC"
49 mkdir -p "$DOC"
50 mkdir -p "$DOC"/rdoff
51 rm -f "$RPM_BUILD_ROOT"/usr/info/nasm.*
52 make INSTALLROOT="$RPM_BUILD_ROOT" docdir=/usr/doc/nasm-%{version} install_everything
53 gzip -9 "$RPM_BUILD_ROOT"/usr/info/nasm.*
54 gzip -9 "$DOC"/*.txt "$DOC"/*.ps
55 cp Changes Licence MODIFIED Readme Wishlist *.doc changed.asm "$DOC"
56 cp rdoff/README rdoff/Changes "$DOC"/rdoff
58 %clean
59 rm -rf "$RPM_BUILD_ROOT"
61 %post doc
62 /sbin/install-info "$RPM_INSTALL_PREFIX"/info/nasm.info.gz "$RPM_INSTALL_PREFIX"/info/dir
64 %preun doc
65 if [ $1 = 0 ]; then
66 /sbin/install-info --delete "$RPM_INSTALL_PREFIX"/info/nasm.info.gz "$RPM_INSTALL_PREFIX"/info/dir
69 %files
70 %attr(-,root,root) /usr/bin/nasm
71 %attr(-,root,root) /usr/bin/ndisasm
72 %attr(-,root,root) %doc /usr/man/man1/nasm.1
73 %attr(-,root,root) %doc /usr/man/man1/ndisasm.1
74 %attr(-,root,root) %doc /usr/doc/nasm-%{version}/Licence
76 %files doc
77 %attr(-,root,root) %doc /usr/info/nasm.info*.gz
78 %attr(-,root,root) %doc /usr/doc/nasm-%{version}/*
80 %files rdoff
81 %attr(-,root,root) /usr/bin/ldrdf
82 %attr(-,root,root) /usr/bin/rdf2bin
83 %attr(-,root,root) /usr/bin/rdf2com
84 %attr(-,root,root) /usr/bin/rdfdump
85 %attr(-,root,root) /usr/bin/rdflib
86 %attr(-,root,root) /usr/bin/rdx
87 %attr(-,root,root) %doc /usr/doc/nasm-%{version}/rdoff/*