Newer claws is fixed
[marcv-overlay.git] / gnome-extra / avant-window-navigator / avant-window-navigator-9999.ebuild
blob19d401bc48af66b4fdd4f5f0a29aad5c5acc6b3a
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
7 EBZR_REPO_URI="lp:awn"
8 PYTHON_DEPEND="2:2.5"
10 inherit autotools bzr gnome2 python
12 DESCRIPTION="Fully customizable dock for the Free desktop"
13 HOMEPAGE="https://launchpad.net/awn"
14 SRC_URI=""
15 LICENSE="GPL-2 LGPL-2.1 CCPL-Attribution-ShareAlike-3.0"
17 SLOT="0"
18 KEYWORDS="*"
19 IUSE="doc gconf vala"
21 COMMON_DEPEND="
22 dev-libs/dbus-glib
23 >=dev-libs/glib-2.16.0
24 dev-python/pycairo
25 dev-python/pygtk:2
26 gnome-base/libgtop
27 >=x11-libs/gtk+-2.12.0
28 x11-libs/libX11
29 x11-libs/libXcomposite
30 x11-libs/libXext
31 x11-libs/libXrender
32 x11-libs/libdesktop-agnostic[gconf?]
33 >=x11-libs/libwnck-2.22
36 RDEPEND="${COMMON_DEPEND}
37 dev-python/pyxdg
39 DEPEND="${COMMON_DEPEND}
40 >=dev-util/gtk-doc-1.4
41 >=dev-util/intltool-0.35.5
42 dev-util/pkgconfig
43 x11-proto/compositeproto
44 x11-proto/renderproto
45 x11-proto/xextproto
46 x11-proto/xproto
47 gconf? ( gnome-base/gconf:2 )
48 vala? ( dev-lang/vala )
51 DOCS="AUTHORS ChangeLog NEWS README TODO"
53 src_unpack() {
54 bzr_src_unpack
57 src_prepare() {
58 gtkdocize || die "gtkdocize failed"
59 intltoolize --copy --force || die "intltoolize failed"
60 eautoreconf || die "eautoreconf failed"
61 # disable pyc compiling - from gnome-python-common.eclass
62 if [[ -f py-compile ]]; then
63 rm py-compile
64 ln -s $(type -P true) py-compile
68 src_configure() {
69 econf $(use_enable doc gtk-doc) \
70 $(use_enable gconf schemas-install) \
71 $(use_with vala) \
72 --disable-static \
73 --disable-pymod-checks \
74 --enable-extra-version=-gentoo-desktop-effects
77 pkg_postinst() {
78 gnome2_pkg_postinst
80 ewarn
81 ewarn "AWN will be of no use if you do not have a compositing manager."
83 python_mod_optimize $(python_get_sitedir)/awn
86 pkg_postrm() {
87 gnome2_pkg_postrm
88 python_mod_cleanup awn