lilypond-0.1.45
[lilypond.git] / debian / rules
blobb71ba55d430c31c94917f9870c965e58c12f3e8c
1 #!/usr/bin/make -f
2 # Made with the aid of debhelper by by Joey Hess,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is free software; see the GNU General Public Licence
6 # version 2 or later for copying conditions. There is NO warranty.
8 # Currently maintained by Anthony Fok <foka@debian.org>
9 # for Debian GNU/Linux.
11 package = lilypond
13 SHELL = /bin/bash
15 # Uncomment this to turn on verbose mode.
16 #export DH_VERBOSE=1
18 build: build-stamp
19 build-stamp:
20 dh_testdir
21 ./configure --disable-checking --disable-debugging \
22 --enable-printing --prefix=/usr --enable-optimise \
23 --enable-shared
24 $(MAKE) all
25 $(MAKE) -C Documentation gifs
26 touch build-stamp
28 clean:
29 dh_testdir
30 dh_testroot
31 rm -f build-stamp
32 -$(MAKE) distclean
33 dh_clean
35 # Build architecture-independent files here.
36 binary-indep: build
37 # We have nothing to do by default.
39 binary-arch: build
40 dh_testdir
41 dh_testroot
42 dh_installdirs usr/lib/texmf/doc usr/lib/emacs/site-lisp
43 ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
44 $(MAKE) prefix=`pwd`/debian/tmp/usr install
45 cp -av bin/out/ly2dvi debian/tmp/usr/bin
46 cp -av mudela-mode.el debian/tmp/usr/lib/emacs/site-lisp
47 dh_installdocs ANNOUNCE ANNOUNCE-0.1 README NEWS ONEWS DEDICATION \
48 BUGS TODO \
49 Documentation/*.doc Documentation/out/{*.txt,*.gif}
50 dh_installexamples input/{*.ly,TODO}
51 cp -aPv `find mutopia \( -name '*.ly' -o -name '*.tex' -o -name 'TODO' \)` \
52 debian/tmp/usr/doc/lilypond/examples
53 # dh_installmenu
54 # dh_installcron
55 # dh_installmanpages
56 # dh_undocumented
57 dh_installchangelogs
58 dh_strip
59 dh_compress
60 dh_fixperms
61 dh_suidregister
62 dh_installdeb
63 dh_shlibdeps
64 dh_gencontrol
65 # dh_makeshlibs
66 dh_du
67 dh_md5sums
68 dh_builddeb
70 source diff:
71 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
73 binary: binary-indep binary-arch
74 .PHONY: build clean binary-indep binary-arch binary