lilypond-0.1.36
[lilypond.git] / debian / rules
blob722ba550ac29787f40d55d778651178d6573f800
1 #!/usr/bin/make -f
2 # Made with the aid of debhelper by by Joey Hess,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is free software; see the GNU General Public Licence
6 # version 2 or later for copying conditions. There is NO warranty.
8 # Currently maintained by Anthony Fok <foka@debian.org>
9 # for Debian GNU/Linux.
11 package=lilypond
13 SHELL=/bin/bash
15 # Uncomment this to turn on verbose mode.
16 #export DH_VERBOSE=1
18 build: build-stamp
19 build-stamp:
20 dh_testdir
21 ./configure --disable-checking --disable-debugging \
22 --enable-printing --prefix=/usr --enable-optimise \
23 --enable-shared
24 make all
25 touch build-stamp
27 clean:
28 dh_testdir
29 dh_testroot
30 rm -f build-stamp
31 -$(MAKE) distclean
32 # Don't put dh_clean before "make distclean"! dh_clean is
33 # "too smart" and it deletes too many files!
34 dh_clean
35 rm -f {,*/}out/{*,.build} flower/config.{log,status}
37 # Build architecture-independent files here.
38 binary-indep: build
39 # We have nothing to do by default.
41 binary-arch: build
42 dh_testdir
43 dh_testroot
44 dh_installdirs usr/lib/texmf/doc
45 $(MAKE) prefix=`pwd`/debian/tmp/usr install
46 ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
47 dh_installdocs BUGS TODO NEWS DEDICATION ANNOUNCE README \
48 Documentation/out/*.text Documentation/*.doc \
49 Documentation/lelie_logo.xpm bin/ly2dvi.sh
50 dh_installexamples input/*.ly input/*.tex
51 # dh_installmenu
52 # dh_installcron
53 # dh_installmanpages
54 # dh_undocumented
55 dh_installchangelogs
56 dh_strip
57 dh_compress
58 dh_fixperms
59 dh_suidregister
60 dh_installdebfiles
61 # dh_makeshlibs
62 dh_du
63 dh_md5sums
64 dh_builddeb
66 binary: binary-indep binary-arch
67 .PHONY: build clean binary-indep binary-arch binary