2 # Made with the aid of debhelper by by Joey Hess,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is free software; see the GNU General Public Licence
6 # version 2 or later for copying conditions. There is NO warranty.
8 # Currently maintained by Anthony Fok <foka@debian.org>
9 # for Debian GNU/Linux.
15 # Uncomment this to turn on verbose mode.
21 .
/configure
--disable-checking
--disable-debugging \
22 --enable-printing
--prefix=/usr
--enable-optimise \
32 # Don't put dh_clean before "make distclean"! dh_clean is
33 # "too smart" and it deletes too many files!
35 rm -f
{,*/}out
/{*,.build
} flower
/config.
{log
,status
}
37 # Build architecture-independent files here.
39 # We have nothing to do by default.
44 dh_installdirs usr
/lib
/texmf
/doc
45 $(MAKE
) prefix=`pwd`/debian
/tmp
/usr
install
46 ln
-fs ..
/..
/..
/doc
/lilypond debian
/tmp
/usr
/lib
/texmf
/doc
/lilypond
47 dh_installdocs BUGS TODO NEWS DEDICATION ANNOUNCE README \
48 Documentation
/out
/*.text Documentation
/*.doc \
49 Documentation
/lelie_logo.xpm bin
/ly2dvi.sh
50 dh_installexamples input
/*.ly input
/*.
tex
66 binary
: binary-indep binary-arch
67 .PHONY
: build
clean binary-indep binary-arch binary