lilypond-0.1.57
[lilypond.git] / debian / rules
blobc0a20793c3fb337461d022ac29263a5523824111
1 #!/usr/bin/make -f
2 # Made with the aid of debhelper by by Joey Hess,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is free software; see the GNU General Public Licence
6 # version 2 or later for copying conditions. There is NO warranty.
8 # Currently maintained by Anthony Fok <foka@debian.org>
9 # for Debian GNU/Linux.
11 package = lilypond
13 SHELL = /bin/bash
15 # Uncomment this to turn on verbose mode.
16 #export DH_VERBOSE=1
18 build: build-stamp
19 build-stamp:
20 dh_testdir
21 ./configure --disable-checking --disable-debugging \
22 --enable-printing --prefix=/usr --enable-optimise \
23 --enable-shared
24 $(MAKE) all
25 touch build-stamp
27 clean:
28 dh_testdir
29 dh_testroot
30 rm -f build-stamp
31 -$(MAKE) distclean
32 dh_clean
34 # Build architecture-independent files here.
35 binary-indep: build
36 # We have nothing to do by default.
38 binary-arch: build
39 dh_testdir
40 dh_testroot
41 dh_installdirs usr/lib/texmf/doc usr/lib/emacs/site-lisp
42 ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
43 $(MAKE) prefix=`pwd`/debian/tmp/usr install
44 cp -av mudela-mode.el debian/tmp/usr/lib/emacs/site-lisp
45 dh_installdocs ANNOUNCE ANNOUNCE-0.1 README NEWS ONEWS DEDICATION \
46 BUGS TODO \
47 Documentation/*.{doc,xpm} Documentation/out/*.txt
48 # Documentation/*.doc Documentation/out/*.{txt,gif}
49 dh_installexamples input/{*.ly,TODO}
50 cp -aPv `find mutopia \( -name '*.ly' -o -name '*.tex' -o -name 'TODO' \)` \
51 debian/tmp/usr/doc/lilypond/examples
52 # dh_installmenu
53 # dh_installcron
54 # dh_installmanpages
55 # dh_undocumented
56 dh_installchangelogs
57 dh_strip
58 dh_compress
59 dh_fixperms
60 dh_suidregister
61 dh_installdeb
62 dh_shlibdeps
63 dh_gencontrol
64 # dh_makeshlibs
65 dh_du
66 dh_md5sums
67 dh_builddeb
69 source diff:
70 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
72 binary: binary-indep binary-arch
73 .PHONY: build clean binary-indep binary-arch binary