lilypond-0.1.33
[lilypond.git] / debian / rules
blob8befb887050076672060548f2edc10c4beacf1b5
1 #!/usr/bin/make -f
2 # Made with the aid of debhelper by by Joey Hess,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 # This is free software; see the GNU General Public Licence
6 # version 2 or later for copying conditions. There is NO warranty.
8 # Currently maintained by Anthony Fok <foka@gpu.srv.ualberta.ca>
9 # for Debian GNU/Linux.
11 package=lilypond
13 SHELL=/bin/bash
15 # Uncomment this to turn on verbose mode.
16 export DH_VERBOSE=1
18 build: build-stamp
19 build-stamp:
20 dh_testdir
21 ./configure --disable-checking --disable-debugging \
22 --enable-printing --prefix=/usr --enable-optimise \
23 --enable-shared
24 make all
25 touch build-stamp
27 clean:
28 dh_testdir
29 dh_testroot
30 rm -f build-stamp
31 dh_clean
32 -$(MAKE) distclean
33 rm -f {,*/}out/{*,.build} flower/config.{log,status}
35 # Build architecture-independent files here.
36 binary-indep: build
37 # We have nothing to do by default.
39 binary-arch: build
40 dh_testdir
41 dh_testroot
42 dh_clean
43 dh_installdirs usr/lib/texmf/doc
44 $(MAKE) prefix=`pwd`/debian/tmp/usr install
45 ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
46 dh_installdocs BUGS TODO NEWS DEDICATION ANNOUNCE README \
47 Documentation/out/*.text Documentation/*.doc \
48 Documentation/lelie_logo.xpm
49 dh_installexamples
50 # dh_installmenu
51 # dh_installcron
52 # dh_installmanpages
53 # dh_undocumented
54 dh_installchangelogs
55 dh_strip
56 dh_compress
57 dh_fixperms
58 dh_suidregister
59 dh_installdebfiles
60 # dh_makeshlibs
61 dh_du
62 dh_md5sums
63 dh_builddeb
65 binary: binary-indep binary-arch
66 .PHONY: build clean binary-indep binary-arch binary