3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
21 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
27 # shared library versions, option 1
30 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
31 #version=`ls src/.libs/lib*.so.* | \
32 # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
33 #major=`ls src/.libs/lib*.so.* | \
34 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
36 config.status
: configure
38 # Add here commands to configure the package.
39 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
40 cp
-f
/usr
/share
/misc
/config.sub config.sub
42 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
43 cp
-f
/usr
/share
/misc
/config.guess config.guess
45 .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) --prefix=/usr
--mandir=\
$${prefix}/share
/man
--infodir=\
$${prefix}/share
/info CFLAGS
="$(CFLAGS)" --enable-hidden-symbols
--enable-gnutls
--enable-ssh
--enable-quality LDFLAGS
="-Wl,-z,defs"
49 build-stamp
: config.status
52 # Add here commands to compile the package.
62 # Add here commands to clean up after the build process.
64 rm -f config.sub config.guess
74 # Add here commands to install the package into debian/tmp
75 $(MAKE
) DESTDIR
=$(CURDIR
)/debian
/tmp
install
76 install -d
$(CURDIR
)/debian
/tmp
/usr
/share
/lintian
/overrides
77 install -m644
$(CURDIR
)/debian
/lintian.overrides debian
/tmp
/usr
/share
/lintian
/overrides
/libpwmd7
80 # Build architecture-independent files here.
81 binary-indep
: build
install
83 # We have nothing to do by default.
85 # Build architecture-dependent files here.
86 binary-arch
: build
install
89 dh_installchangelogs ChangeLog
92 dh_install
--sourcedir
=debian
/tmp
116 binary
: binary-indep binary-arch
117 .PHONY
: build
clean binary-indep binary-arch binary
install