contrib: Add helper to build Android dependencies.
[libpwmd.git] / debian / rules
blobcd02aeb0380f984b30acbd75c1ede08105c0ff3f
1 #!/usr/bin/make -f
2 # You must remove unused comment lines for the released package.
3 export DH_VERBOSE = 1
4 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
5 export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
6 export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
8 %:
9 dh $@ --with autoreconf
11 override_dh_auto_configure:
12 dh_auto_configure -- \
13 --enable-gnutls \
14 --enable-ssh \
15 --enable-hidden-symbols
17 #override_dh_autoreconf:
18 # dh_autoreconf -- ./autogen.sh
19 #override_dh_install:
20 # dh_install --list-missing -X.la -X.pyc -X.pyo