Now the systrayicon change it's color when a download is in progress. I simply change...
[kdenetwork.git] / debian / rules
blob791084e72aa92347411f3321ebb1d9a2855b7c65
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Modified to make a template file for a multi-binary package with separated
7 # build-arch and build-indep targets by Bill Allombert 2001
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 # This has to be exported to make some magic below work.
13 export DH_OPTIONS
15 # These are used for cross-compiling and for saving the configure script
16 # from having to guess our platform (since we know it already)
17 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
20 CFLAGS = -Wall -g
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 CFLAGS += -O0
24 else
25 CFLAGS += -O2
26 endif
27 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
28 INSTALL_PROGRAM += -s
29 endif
31 objdir = $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
33 -include debian/debiandirs
35 debian/debiandirs: admin/debianrules
36 perl -w admin/debianrules echodirs > debian/debiandirs
38 configure: configure-stamp
39 configure-stamp:
40 dh_testdir
42 # Apply Debian specific patches
43 if test -d $(CURDIR)/debian/patches ;\
44 then \
45 for i in $(CURDIR)/debian/patches/*.diff.uu ;\
46 do \
47 cd $(CURDIR)/debian/patches ;\
48 uudecode "$$i" ;\
49 cd $(CURDIR) ;\
50 done ;\
51 patches=$$(find $(CURDIR)/debian/patches -name *.diff | sort);\
52 fi ;\
53 if test ! -f patch-stamp; then \
54 for patch in $$patches ;\
55 do \
56 echo APPLYING PATCH\: "$${patch##*/}" ;\
57 patch -p1 < "$$patch" ;\
58 done ;\
59 touch patch-stamp ;\
62 # KDE CVS does not have aclocal.m4 or configure
63 if test ! -f configure; then \
64 $(MAKE) -f admin/Makefile.common ;\
67 # ensure configure is executable
68 chmod +x configure
70 # make build directory
71 mkdir $(objdir)
73 # run configure with build tree $(objdir)
74 cd $(objdir) && \
75 ../configure $(configkde) --enable-final
77 touch configure-stamp
79 #Architecture
80 build: build-arch build-indep
82 build-arch: build-arch-stamp
83 build-arch-stamp: configure-stamp
84 dh_testdir
86 cd $(objdir) && \
87 $(MAKE)
89 # generate manpages
90 for i in debian/man/*.sgml; do \
91 docbook-to-man $$i > `dirname $$i`/`basename $$i .sgml`.1 ;\
92 done
94 touch build-arch-stamp
96 build-indep: build-indep-stamp
97 build-indep-stamp: configure-stamp
98 dh_testdir
100 cd $(objdir) && \
101 $(MAKE)
103 #cd $(objdir) && \
104 $(MAKE) apidox
106 touch build-indep-stamp
108 debian-clean:
109 dh_testdir
110 dh_testroot
112 dh_clean
114 clean:
115 dh_testdir
116 dh_testroot
117 rm -f build-arch-stamp build-indep-stamp configure-stamp \
118 debian/debiandirs debian/man/*.1
120 # Remove Debian specific patches
121 if test -d $(CURDIR)/debian/patches ;\
122 then \
123 patches=$$(find $(CURDIR)/debian/patches -name *.diff | sort -r);\
124 fi ;\
125 if test -f patch-stamp; then \
126 for patch in $$patches ;\
127 do \
128 echo REMOVING PATCH\: "$${patch##*/}" ;\
129 patch -p1 -R < "$$patch" ;\
130 done ;\
131 for i in $(CURDIR)/debian/patches/*.diff.uu ;\
132 do \
133 rm -f "$${i%%.uu}" ;\
134 done ;\
135 rm -f patch-stamp ;\
138 # Remove build tree
139 rm -rf $(objdir)
141 # if Makefile exists run distclean
142 if test -f Makefile; then \
143 $(MAKE) distclean; \
146 if test -d CVS; then \
147 $(MAKE) -f admin/Makefile.common cvs-clean ;\
150 dh_clean
152 install: install-arch install-indep
154 install-arch:
155 dh_testdir
156 dh_testroot
157 dh_clean -k -s
158 dh_installdirs -s
160 cd $(objdir) && \
161 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
163 # kppp permissions
164 chown root:dip debian/tmp/usr/bin/kppp*
165 chmod 2754 debian/tmp/usr/bin/kppp
166 chmod 0754 debian/tmp/usr/bin/kppplogview
168 #chmod 4755 debian/tmp/usr/sbin/reslisa
170 dh_install -s
172 install-indep:
173 dh_testdir
174 dh_testroot
175 dh_clean -k -i
176 dh_installdirs -i
178 cd $(objdir) && \
179 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
181 #cd $(objdir) && \
182 $(MAKE) install-apidox DESTDIR=$(CURDIR)/debian/tmp
184 dh_install -i
186 # Must not depend on anything. This is to be called by
187 # binary-arch/binary-indep
188 # in another 'make' thread.
189 binary-common:
190 dh_testdir
191 dh_testroot
192 dh_installchangelogs
193 dh_installdocs
194 # dh_installexamples
195 dh_installmenu
196 # dh_installdebconf
197 # dh_installlogrotate
198 # dh_installemacsen
199 # dh_installpam
200 dh_installmime
201 dh_installinit
202 # dh_installcron
203 # dh_installinfo
204 dh_installman
205 dh_link
206 dh_strip
207 dh_compress -X.bz2 -X.css -X.dcl -X.docbook -X-license -X.tag
208 dh_fixperms -Xusr/bin/kppp -Xusr/bin/kppplogview
209 dh_perl
210 # dh_python
211 dh_makeshlibs -V
212 dh_installdeb
213 dh_shlibdeps -ldebian/kopete/usr/lib:debian/librss1/usr/lib
214 dh_gencontrol
215 dh_md5sums
216 dh_builddeb
218 # Build architecture independant packages using the common target.
219 binary-indep: build-indep install-indep
220 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
222 # Build architecture dependant packages using the common target.
223 binary-arch: build-arch install-arch
224 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
226 binary: binary-arch binary-indep
227 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure