Now the systrayicon change it's color when a download is in progress. I simply change...
[kdenetwork.git] / debian / ktalkd.postinst
blob44dfd6c2495c3434762ed86bb9ab1442fd2f49db
1 #! /bin/sh
2 # postinst script for ktalkd
4 # see: dh_installdeb(1)
6 set -e
8 talk_entry="talk dgram udp wait nobody.tty /usr/sbin/tcpd /usr/sbin/ktalkd"
9 ntalk_entry="ntalk dgram udp wait nobody.tty /usr/sbin/tcpd /usr/sbin/ktalkd"
11 enable_talk() {
12 update-inetd --pattern '[ \t]/usr/sbin/ktalkd' --enable talk
13 update-inetd --pattern '[ \t]/usr/sbin/ktalkd' --enable ntalk
16 remove_talk() {
17 update-inetd --remove 'talk[ \t].*[ \t]/usr/sbin/ktalkd'
18 update-inetd --remove 'ntalk[ \t].*[ \t]/usr/sbin/ktalkd'
21 case "$1" in
22 configure)
23 remove_talk
24 if grep -q ^talk /etc/inetd.conf; then
25 update-inetd --group BSD --add "#$talk_entry"
26 update-inetd --group BSD --add "#$ntalk_entry"
27 else
28 update-inetd --group BSD --add "$talk_entry"
29 update-inetd --group BSD --add "$ntalk_entry"
33 abort-upgrade|abort-remove|abort-deconfigure)
34 enable_talk
38 echo "postinst called with unknown argument \`$1'" >&2
39 exit 1
41 esac
43 # dh_installdeb will replace this with shell code automatically
44 # generated by other debhelper scripts.
46 #DEBHELPER#
48 exit 0