log10l: Work around inaccurate implementation on NetBSD.
[gnulib.git] / build-aux / gcc-warning.spec
blob8c0a3dc7503d09bcffc7164cadb94ba84fe185ff
1 # options to filter out, and why
2 --all-warnings alias for -Wall
3 --extra-warnings alias for -Wextra
4 -Wabi-tag c++
5 -Wabi= c++
6 -Wabi this is now a no-op
7 -Waggregate-return obsolescent
8 -Waliasing fortran
9 -Walign-commons fortran
10 -Waligned-new=[none|global|all] c++
11 -Walloca we like alloca in small doses
12 -Walloca-larger-than=<number> FIXME: choose something sane?
13 -Walloc-size-larger-than= handled specially by gl_MANYWARN_ALL_GCC
14 -Walloc-zero Gnulib fixes this problem
15 -Wampersand fortran
16 -Wargument-mismatch fortran
17 -Warray-bounds covered by -Warray-bounds=
18 -Warray-bounds=<0,2> handled specially by gl_MANYWARN_ALL_GCC
19 -Warray-temporaries fortran
20 -Wassign-intercept objc/objc++
21 -Wc++-compat only useful for code meant to be compiled by a C++ compiler
22 -Wc++0x-compat c++
23 -Wc++11-compat c++
24 -Wc++14-compat c++
25 -Wc++17-compat c++
26 -Wc++1z-compat c++
27 -Wc-binding-type fortran
28 -Wc90-c99-compat c compatibility
29 -Wc99-c11-compat c compatibility
30 -Wcast-qual FIXME maybe? too much noise; encourages bad changes
31 -Wcatch-value c++
32 -Wcatch-value=<0,3> c++
33 -Wcharacter-truncation fortran
34 -Wchkp deprecated
35 -Wclass-memaccess c++
36 -Wcompare-reals fortran
37 -Wconditionally-supported c++ and objc++
38 -Wconversion FIXME maybe? too much noise; encourages bad changes
39 -Wconversion-extra fortran
40 -Wconversion-null c++ and objc++
41 -Wctor-dtor-privacy c++
42 -Wdeclaration-after-statement FIXME: do not want. others may
43 -Wdelete-incomplete c++ and objc++
44 -Wdelete-non-virtual-dtor c++
45 -Wdo-subscript fortran
46 -Weffc++ c++
47 -Werror-implicit-function-declaration deprecated
48 -Wextra-semi c++
49 -Wfloat-conversion FIXME maybe? borderline. some will want this
50 -Wfloat-equal FIXME maybe? borderline. some will want this
51 -Wformat covered by -Wformat=2
52 -Wformat=<0,2> gcc --help=warnings artifact
53 -Wformat-overflow<0,2> gcc --help=warnings artifact
54 -Wformat-overflow=<0,2> handled specially by gl_MANYWARN_ALL_GCC
55 -Wformat-truncation covered by -Wformat-truncation=2
56 -Wformat-truncation=<0,2> handled specially by gl_MANYWARN_ALL_GCC
57 -Wframe-larger-than=<number> FIXME: choose something sane?
58 -Wfunction-elimination fortran
59 -Wimplicit-fallthrough covered by -Wimplicit-fallthrough=2
60 -Wimplicit-fallthrough=<0,5> handled specially by gl_MANYWARN_ALL_GCC
61 -Wimplicit-interface fortran
62 -Wimplicit-procedure fortran
63 -Winherited-variadic-ctor c++
64 -Winteger-division fortran
65 -Wintrinsic-shadow fortran
66 -Wintrinsics-std fortran
67 -Winvalid-offsetof c++ and objc++
68 -Wjump-misses-init only useful for code meant to be compiled by a C++ compiler
69 -Wlarger-than- gcc --help=warnings artifact
70 -Wlarger-than=<number> FIXME: choose something sane?
71 -Wline-truncation fortran
72 -Wliteral-suffix c++ and objc++
73 -Wlong-long obsolescent
74 -Wlto-type-mismatch c++ and objc++
75 -Wmissing-format-attribute obsolescent
76 -Wmissing-noreturn obsolescent
77 -Wmultiple-inheritance c++ and objc++
78 -Wnamespaces c++
79 -Wnoexcept c++
80 -Wnoexcept-type c++
81 -Wnon-template-friend c++
82 -Wnon-virtual-dtor c++
83 -Wnormalized covered by -Wnormalized=
84 -Wnormalized=[none|id|nfc|nfkc] handled specially by gl_MANYWARN_ALL_GCC
85 -Wold-style-cast c++ and objc++
86 -Woverloaded-virtual c++
87 -Woverride-init-side-effects c++ and objc++
88 -Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
89 -Wpedantic FIXME: too strict?
90 -Wplacement-new c++
91 -Wplacement-new=<0,2> c++
92 -Wpmf-conversions c++ and objc++
93 -Wproperty-assign-default objc++
94 -Wprotocol objc++
95 -Wreal-q-constant fortran
96 -Wrealloc-lhs fortran
97 -Wrealloc-lhs-all fortran
98 -Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
99 -Wregister c++ and objc++
100 -Wreorder c++ and objc++
101 -Wselector objc and objc++
102 -Wshadow-ivar objc
103 -Wshadow=compatible-local covered by -Wshadow
104 -Wshadow-compatible-local covered by -Wshadow
105 -Wshadow=global covered by -Wshadow
106 -Wshadow=local covered by -Wshadow
107 -Wshadow-local covered by -Wshadow
108 -Wshift-overflow covered by -Wshift-overflow=2
109 -Wshift-overflow=<0,2> gcc --help=warnings artifact
110 -Wsign-compare FIXME maybe? borderline. some will want this
111 -Wsign-conversion FIXME maybe? borderline. some will want this
112 -Wsign-promo c++ and objc++
113 -Wsized-deallocation c++ and objc++
114 -Wstack-usage=<number> FIXME: choose something sane?
115 -Wstrict-aliasing=<0,3> FIXME: choose something sane?
116 -Wstrict-null-sentinel c++ and objc++
117 -Wstrict-overflow=<0,5> FIXME: choose something sane?
118 -Wstrict-selector-match objc and objc++
119 -Wstringop-overflow covered by -Wstringop-overflow=
120 -Wstringop-overflow=<0,4> handled specially by gl_MANYWARN_ALL_GCC
121 -Wsubobject-linkage c++ and objc++
122 -Wsuggest-override c++ and objc++
123 -Wsurprising fortran
124 -Wswitch-default https://lists.gnu.org/r/bug-gnulib/2018-05/msg00179.html
125 -Wswitch-enum FIXME maybe? borderline. some will want this
126 -Wsynth deprecated
127 -Wtabs fortran
128 -Wtarget-lifetime fortran
129 -Wtemplates c++ and objc++
130 -Wterminate c++ and objc++
131 -Wtraditional obsolescent
132 -Wtraditional-conversion obsolescent
133 -Wundeclared-selector objc and objc++
134 -Wundef FIXME maybe? too many false positives
135 -Wundefined-do-loop fortran
136 -Wunderflow fortran
137 -Wunreachable-code obsolescent no-op
138 -Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
139 -Wunused-const-variable covered by -Wunusec-const-variable=2
140 -Wunused-const-variable=<0,2> gcc --help=warnings artifact
141 -Wunused-dummy-argument fortran
142 -Wuse-without-only fortran
143 -Wuseless-cast c++ and objc++
144 -Wvirtual-inheritance c++
145 -Wvirtual-move-assign c++
146 -Wvla-larger-than=<number> handled specially by gl_MANYWARN_ALL_GCC
147 -Wzero-as-null-pointer-constant c++ and objc++
148 -Wzerotrip fortran
149 -frequire-return-statement go