manywarnings: port to GCC 8.0
[gnulib.git] / build-aux / gcc-warning.spec
blob2ffdb2ba4539785a5e34568bf30e8ea95eab8a17
1 # options to filter out, and why
2 --all-warnings alias for -Wall
3 --extra-warnings alias for -Wextra
4 -Wabi-tag c++
5 -Wabi= c++
6 -Waggregate-return obsolescent
7 -Waliasing fortran
8 -Walign-commons fortran
9 -Waligned-new=[none|global|all] c++
10 -Walloca we like alloca in small doses
11 -Walloca-larger-than=<number> FIXME: choose something sane?
12 -Walloc-size-larger-than= handled specially by gl_MANYWARN_ALL_GCC
13 -Walloc-zero Gnulib fixes this problem
14 -Wampersand fortran
15 -Wargument-mismatch fortran
16 -Warray-bounds covered by -Warray-bounds=
17 -Warray-bounds=<0,2> handled specially by gl_MANYWARN_ALL_GCC
18 -Warray-temporaries fortran
19 -Wassign-intercept objc/objc++
20 -Wc++-compat FIXME maybe? borderline. some will want this
21 -Wc++0x-compat c++
22 -Wc++11-compat c++
23 -Wc++14-compat c++
24 -Wc++17-compat c++
25 -Wc++1z-compat c++
26 -Wc-binding-type fortran
27 -Wc90-c99-compat c compatibility
28 -Wc99-c11-compat c compatibility
29 -Wcast-qual FIXME maybe? too much noise; encourages bad changes
30 -Wcatch-value c++
31 -Wcatch-value=<0,3> c++
32 -Wcharacter-truncation fortran
33 -Wclass-memaccess c++
34 -Wcompare-reals fortran
35 -Wconditionally-supported c++ and objc++
36 -Wconversion FIXME maybe? too much noise; encourages bad changes
37 -Wconversion-extra fortran
38 -Wconversion-null c++ and objc++
39 -Wctor-dtor-privacy c++
40 -Wdeclaration-after-statement FIXME: do not want. others may
41 -Wdelete-incomplete c++ and objc++
42 -Wdelete-non-virtual-dtor c++
43 -Wdo-subscript fortran
44 -Weffc++ c++
45 -Werror-implicit-function-declaration deprecated
46 -Wextra-semi c++
47 -Wfloat-conversion FIXME maybe? borderline. some will want this
48 -Wfloat-equal FIXME maybe? borderline. some will want this
49 -Wformat covered by -Wformat=2
50 -Wformat=<0,2> gcc --help=warnings artifact
51 -Wformat-overflow<0,2> gcc --help=warnings artifact
52 -Wformat-overflow=<0,2> handled specially by gl_MANYWARN_ALL_GCC
53 -Wformat-truncation covered by -Wformat-truncation=2
54 -Wformat-truncation=<0,2> handled specially by gl_MANYWARN_ALL_GCC
55 -Wframe-larger-than=<number> FIXME: choose something sane?
56 -Wfunction-elimination fortran
57 -Wimplicit-fallthrough covered by -Wimplicit-fallthrough=2
58 -Wimplicit-fallthrough=<0,5> handled specially by gl_MANYWARN_ALL_GCC
59 -Wimplicit-interface fortran
60 -Wimplicit-procedure fortran
61 -Winherited-variadic-ctor c++
62 -Winteger-division fortran
63 -Wintrinsic-shadow fortran
64 -Wintrinsics-std fortran
65 -Winvalid-offsetof c++ and objc++
66 -Wlarger-than- gcc --help=warnings artifact
67 -Wlarger-than=<number> FIXME: choose something sane?
68 -Wline-truncation fortran
69 -Wliteral-suffix c++ and objc++
70 -Wlong-long obsolescent
71 -Wlto-type-mismatch c++ and objc++
72 -Wmissing-format-attribute obsolescent
73 -Wmissing-noreturn obsolescent
74 -Wmultiple-inheritance c++ and objc++
75 -Wnamespaces c++
76 -Wnoexcept c++
77 -Wnoexcept-type c++
78 -Wnon-template-friend c++
79 -Wnon-virtual-dtor c++
80 -Wnormalized covered by -Wnormalized=
81 -Wnormalized=[none|id|nfc|nfkc] handled specially by gl_MANYWARN_ALL_GCC
82 -Wold-style-cast c++ and objc++
83 -Woverloaded-virtual c++
84 -Woverride-init-side-effects c++ and objc++
85 -Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
86 -Wpedantic FIXME: too strict?
87 -Wplacement-new c++
88 -Wplacement-new=<0,2> c++
89 -Wpmf-conversions c++ and objc++
90 -Wproperty-assign-default objc++
91 -Wprotocol objc++
92 -Wreal-q-constant fortran
93 -Wrealloc-lhs fortran
94 -Wrealloc-lhs-all fortran
95 -Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
96 -Wregister c++ and objc++
97 -Wreorder c++ and objc++
98 -Wselector objc and objc++
99 -Wshadow-ivar objc
100 -Wshadow=compatible-local covered by -Wshadow
101 -Wshadow-compatible-local covered by -Wshadow
102 -Wshadow=global covered by -Wshadow
103 -Wshadow=local covered by -Wshadow
104 -Wshadow-local covered by -Wshadow
105 -Wshift-overflow covered by -Wshift-overflow=2
106 -Wshift-overflow=<0,2> gcc --help=warnings artifact
107 -Wsign-compare FIXME maybe? borderline. some will want this
108 -Wsign-conversion FIXME maybe? borderline. some will want this
109 -Wsign-promo c++ and objc++
110 -Wsized-deallocation c++ and objc++
111 -Wstack-usage=<number> FIXME: choose something sane?
112 -Wstrict-aliasing=<0,3> FIXME: choose something sane?
113 -Wstrict-null-sentinel c++ and objc++
114 -Wstrict-overflow=<0,5> FIXME: choose something sane?
115 -Wstrict-selector-match objc and objc++
116 -Wstringop-overflow covered by -Wstringop-overflow=
117 -Wstringop-overflow=<0,4> handled specially by gl_MANYWARN_ALL_GCC
118 -Wsubobject-linkage c++ and objc++
119 -Wsuggest-override c++ and objc++
120 -Wsurprising fortran
121 -Wswitch-enum FIXME maybe? borderline. some will want this
122 -Wsynth deprecated
123 -Wtabs fortran
124 -Wtarget-lifetime fortran
125 -Wtemplates c++ and objc++
126 -Wterminate c++ and objc++
127 -Wtraditional obsolescent
128 -Wtraditional-conversion obsolescent
129 -Wundeclared-selector objc and objc++
130 -Wundef FIXME maybe? too many false positives
131 -Wundefined-do-loop fortran
132 -Wunderflow fortran
133 -Wunreachable-code obsolescent no-op
134 -Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
135 -Wunused-const-variable covered by -Wunusec-const-variable=2
136 -Wunused-const-variable=<0,2> gcc --help=warnings artifact
137 -Wunused-dummy-argument fortran
138 -Wuse-without-only fortran
139 -Wuseless-cast c++ and objc++
140 -Wvirtual-inheritance c++
141 -Wvirtual-move-assign c++
142 -Wvla-larger-than=<number> handled specially by gl_MANYWARN_ALL_GCC
143 -Wzero-as-null-pointer-constant c++ and objc++
144 -Wzerotrip fortran
145 -frequire-return-statement go