1 # options to filter out, and why
2 --all
-warnings
alias for -Wall
3 --extra
-warnings
alias for -Wextra
4 -frequire
-return-statement go
5 -Waggregate
-return obsolescent
7 -Walign
-commons fortran
9 -Warray
-bounds covered by
-Warray
-bounds
=
10 -Warray
-bounds
= handled specially by gl_MANYWARN_ALL_GCC
11 -Warray
-temporaries fortran
12 -Wassign
-intercept objc
/objc
++
14 -Wc
++0x
-compat c
++ compatibility
15 -Wc
++11-compat c
++ compatibility
16 -Wc
++14-compat c
++ compatibility
17 -Wc90
-c99
-compat c compatibility
18 -Wc99
-c11
-compat c compatibility
19 -Wcast
-qual FIXME maybe? too much noise
; encourages bad changes
21 -Wc
-binding
-type fortran
22 -Wc
++-compat FIXME maybe? borderline. some will want this
23 -Wcharacter
-truncation fortran
24 -Wcompare
-reals fortran
25 -Wconversion
-extra fortran
26 -Wconversion FIXME maybe? too much noise
; encourages bad changes
27 -Wdeclaration
-after
-statement FIXME
: do not want. others may
29 -Wdiscarded
-array
-qualifiers c
30 -Wdiscarded
-qualifiers c
31 -Werror
-implicit
-function-declaration deprecated
32 -Wfloat
-conversion FIXME maybe? borderline. some will want this
33 -Wfloat
-equal FIXME maybe? borderline. some will want this
34 -Wformat covered by
-Wformat
=2
35 -Wformat
= gcc
--help=warnings artifact
36 -Wframe
-larger
-than
=<number
> FIXME
: choose something sane?
37 -Wfunction
-elimination fortran
39 -Wimplicit
-function-declaration c
41 -Wimplicit
-interface fortran
42 -Wimplicit
-procedure fortran
43 -Wincompatible
-pointer
-types c
45 -Winteger
-division fortran
46 -Wintrinsic
-shadow fortran
47 -Wintrinsics
-std fortran
49 -Wlarger
-than
- gcc
--help=warnings artifact
50 -Wlarger
-than
=<number
> FIXME
: choose something sane?
51 -Wline
-truncation fortran
52 -Wlong
-long obsolescent
53 -Wmissing
-format
-attribute obsolescent
54 -Wmissing
-noreturn obsolescent
55 -Wmissing
-parameter
-type c
56 -Wmissing
-prototypes c
58 -Wnormalized covered by
-Wnormalized
=
59 -Wnormalized
=<none|id|nfc|nfkc
> handled specially by gl_MANYWARN_ALL_GCC
60 -Wold
-style
-declaration c
61 -Wold
-style
-definition c
63 -Wpadded FIXME maybe? warns about "stabil" member
in /usr
/include
/bits
/timex.h
64 -Wpedantic FIXME
: too strict?
66 -Wpointer
-to
-int
-cast c
67 -Wproperty
-assign
-default objc
++
69 -Wrealloc
-lhs
-all fortran
71 -Wreal
-q
-constant fortran
72 -Wredundant
-decls FIXME maybe? many _gl_cxxalias_dummy FPs
73 -Wselector objc and objc
++
75 -Wshift
-overflow covered by
-Wshift
-overflow
=2
76 -Wshift
-overflow
= gcc
--help=warnings artifact
77 -Wsign
-compare FIXME maybe? borderline. some will want this
78 -Wsign
-conversion FIXME maybe? borderline. some will want this
79 -Wstack
-usage
= FIXME
: choose something sane?
80 -Wstrict
-aliasing
= FIXME
: choose something sane?
81 -Wstrict
-overflow
= FIXME
: choose something sane?
83 -Wstrict
-selector
-match objc and objc
++
85 -Wswitch
-default https
://lists.gnu.org
/r
/bug
-gnulib
/2018-05/msg00179.html
86 -Wswitch
-enum FIXME maybe? borderline. some will want this
89 -Wtarget
-lifetime fortran
90 -Wtraditional
-conversion obsolescent
91 -Wtraditional obsolescent
92 -Wundeclared
-selector objc and objc
++
93 -Wundef FIXME maybe? too many false positives
95 -Wunreachable
-code obsolescent no
-op
96 -Wunsuffixed
-float
-constants triggers warning
in gnulib's timespec.h
97 -Wunused
-const
-variable covered by
-Wunusec
-const
-variable
=2
98 -Wunused
-const
-variable
= gcc
--help=warnings artifact
99 -Wunused
-dummy
-argument fortran
100 -Wuse
-without
-only fortran