error: Avoid "function declaration isn't a prototype" warning.
[gnulib.git] / build-aux / gcc-warning.spec
blob8c3901770c0e7fc0a59c1e2f16e85ced83566b8e
1 # options to filter out, and why
2 --all-warnings alias for -Wall
3 --extra-warnings alias for -Wextra
4 -Wabi-tag c++
5 -Wabi= c++
6 -Waggregate-return obsolescent
7 -Waliasing fortran
8 -Walign-commons fortran
9 -Wampersand fortran
10 -Warray-bounds covered by -Warray-bounds=
11 -Warray-bounds= handled specially by gl_MANYWARN_ALL_GCC
12 -Warray-temporaries fortran
13 -Wassign-intercept objc/objc++
14 -Wc++-compat FIXME maybe? borderline. some will want this
15 -Wc++0x-compat c++
16 -Wc++11-compat c++
17 -Wc++14-compat c++
18 -Wc-binding-type fortran
19 -Wc90-c99-compat c compatibility
20 -Wc99-c11-compat c compatibility
21 -Wcast-qual FIXME maybe? too much noise; encourages bad changes
22 -Wcharacter-truncation fortran
23 -Wcompare-reals fortran
24 -Wconditionally-supported c++ and objc++
25 -Wconversion FIXME maybe? too much noise; encourages bad changes
26 -Wconversion-extra fortran
27 -Wconversion-null c++ and objc++
28 -Wctor-dtor-privacy c++
29 -Wdeclaration-after-statement FIXME: do not want. others may
30 -Wdelete-incomplete c++ and objc++
31 -Wdelete-non-virtual-dtor c++
32 -Weffc++ c++
33 -Werror-implicit-function-declaration deprecated
34 -Wfloat-conversion FIXME maybe? borderline. some will want this
35 -Wfloat-equal FIXME maybe? borderline. some will want this
36 -Wformat covered by -Wformat=2
37 -Wformat= gcc --help=warnings artifact
38 -Wframe-larger-than=<number> FIXME: choose something sane?
39 -Wfunction-elimination fortran
40 -Wimplicit-interface fortran
41 -Wimplicit-procedure fortran
42 -Winherited-variadic-ctor c++
43 -Winteger-division fortran
44 -Wintrinsic-shadow fortran
45 -Wintrinsics-std fortran
46 -Winvalid-offsetof c++ and objc++
47 -Wlarger-than- gcc --help=warnings artifact
48 -Wlarger-than=<number> FIXME: choose something sane?
49 -Wline-truncation fortran
50 -Wliteral-suffix c++ and objc++
51 -Wlong-long obsolescent
52 -Wlto-type-mismatch c++ and objc++
53 -Wmissing-format-attribute obsolescent
54 -Wmissing-noreturn obsolescent
55 -Wmultiple-inheritance c++ and objc++
56 -Wnamespaces c++
57 -Wnoexcept c++
58 -Wnon-template-friend c++
59 -Wnon-virtual-dtor c++
60 -Wnormalized covered by -Wnormalized=
61 -Wnormalized=<none|id|nfc|nfkc> handled specially by gl_MANYWARN_ALL_GCC
62 -Wold-style-cast c++ and objc++
63 -Woverloaded-virtual c++
64 -Woverride-init-side-effects c++ and objc++
65 -Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
66 -Wpedantic FIXME: too strict?
67 -Wplacement-new c++
68 -Wplacement-new= c++
69 -Wpmf-conversions c++ and objc++
70 -Wproperty-assign-default objc++
71 -Wprotocol objc++
72 -Wreal-q-constant fortran
73 -Wrealloc-lhs fortran
74 -Wrealloc-lhs-all fortran
75 -Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
76 -Wreorder c++ and objc++
77 -Wselector objc and objc++
78 -Wshadow-ivar objc
79 -Wshift-overflow covered by -Wshift-overflow=2
80 -Wshift-overflow= gcc --help=warnings artifact
81 -Wsign-compare FIXME maybe? borderline. some will want this
82 -Wsign-conversion FIXME maybe? borderline. some will want this
83 -Wsign-promo c++ and objc++
84 -Wsized-deallocation c++ and objc++
85 -Wstack-usage= FIXME: choose something sane?
86 -Wstrict-aliasing= FIXME: choose something sane?
87 -Wstrict-null-sentinel c++ and objc++
88 -Wstrict-overflow= FIXME: choose something sane?
89 -Wstrict-selector-match objc and objc++
90 -Wsubobject-linkage c++ and objc++
91 -Wsuggest-override c++ and objc++
92 -Wsurprising fortran
93 -Wswitch-enum FIXME maybe? borderline. some will want this
94 -Wsynth deprecated
95 -Wtabs fortran
96 -Wtarget-lifetime fortran
97 -Wtemplates c++ and objc++
98 -Wterminate c++ and objc++
99 -Wtraditional obsolescent
100 -Wtraditional-conversion obsolescent
101 -Wundeclared-selector objc and objc++
102 -Wundef FIXME maybe? too many false positives
103 -Wunderflow fortran
104 -Wunreachable-code obsolescent no-op
105 -Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
106 -Wunused-const-variable covered by -Wunusec-const-variable=2
107 -Wunused-const-variable= gcc --help=warnings artifact
108 -Wunused-dummy-argument fortran
109 -Wuse-without-only fortran
110 -Wuseless-cast c++ and objc++
111 -Wvirtual-inheritance c++
112 -Wvirtual-move-assign c++
113 -Wzero-as-null-pointer-constant c++ and objc++
114 -Wzerotrip fortran
115 -frequire-return-statement go