4 # Uncomment this to turn on verbose mode.
8 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
16 # On PowerPC we compile against the hand-crafted assembly, on all
17 # other architectures we compile against GPL'ed sha1 code lifted
18 # from Mozilla. OpenSSL is strangely licensed and best avoided
21 HOST_ARCH
=$(shell dpkg-architecture
-qDEB_HOST_ARCH
)
22 ifeq (${HOST_ARCH},powerpc
)
23 export PPC_SHA1
=YesPlease
25 export MOZILLA_SHA1
=YesPlease
28 # We do have the requisite perl modules in the mainline, and
29 # have no reason to shy away from this script.
30 export WITH_SEND_EMAIL
=YesPlease
33 MANDIR
:= /usr
/share
/man
/
37 DESTDIR
:= $(CURDIR
)/debian
/tmp
38 DOC_DESTDIR
:= $(DESTDIR
)/usr
/share
/doc
/git-core
/
39 MAN_DESTDIR
:= $(DESTDIR
)/$(MANDIR
)
41 build
: debian
/build-stamp
44 $(MAKE
) prefix=$(PREFIX
) PYTHON_PATH
=/usr
/bin
/python2.4
all doc
test
45 touch debian
/build-stamp
50 rm -f debian
/build-stamp
62 make DESTDIR
=$(DESTDIR
) prefix=$(PREFIX
) mandir=$(MANDIR
) \
65 mkdir
-p
$(DOC_DESTDIR
)
66 find
$(DOC
) '(' -name
'*.txt' -o
-name
'*.html' ')' -exec
install {} $(DOC_DESTDIR
) ';'
68 dh_movefiles
-p git-tk
69 dh_movefiles
-p git-core
70 find debian
/tmp
-type d
-o
-print | sed
-e
's/^/? /'
72 binary-arch
: build
install
75 dh_installchangelogs
-a
88 binary-indep
: build
install
91 dh_installchangelogs
-i
102 binary
: binary-arch binary-indep
104 .PHONY
: build
clean binary
install clean debian-clean