dev-libs/v2ray-rules-dat: add 202310262208, drop 202309062208
[gentoo-zh.git] / games-board / othello / othello-0.2.2.ebuild
blob926fd80a5041122d7629b3912f6495b2e4bb0f59
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 WX_GTK_VER="3.0-gtk3"
7 inherit wxwidgets
9 DESCRIPTION="Othello is a classic strategy game, also known as Reversi"
10 HOMEPAGE="http://othello-game.sourceforge.net"
11 SRC_URI="https://github.com/bekcpear/othello/archive/refs/tags/0.2.2.tar.gz -> ${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
17 DEPEND="dev-libs/boost
18 x11-libs/wxGTK:${WX_GTK_VER}"
19 RDEPEND="${DEPEND}"
21 pkg_setup() {
22 setup-wxwidgets
25 src_configure() {
26 ./autogen.sh || die
27 # only python2 supported but boost not
28 econf "--disable-python"