app-editors/zed: add 0.143.7, drop 0.143.6
[gentoo-zh.git] / games-board / othello / othello-0.2.2.ebuild
blob74661fb23745c138ca6f4ec20b9cfee78ece3310
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 WX_GTK_VER="3.0-gtk3"
7 inherit wxwidgets
9 DESCRIPTION="Othello is a classic strategy game, also known as Reversi"
10 HOMEPAGE="http://othello-game.sourceforge.net"
11 SRC_URI="https://github.com/bekcpear/othello/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
17 DEPEND="dev-libs/boost
18 x11-libs/wxGTK:${WX_GTK_VER}"
19 RDEPEND="${DEPEND}"
21 RESTRICT="test" # tests fail
23 pkg_setup() {
24 setup-wxwidgets
27 src_configure() {
28 ./autogen.sh || die
29 # only python2 supported but boost not
30 econf "--disable-python"