frobtads: Don't install ChangeLog file
[gentoo-interactive-fiction.git] / games-engines / frobtads / frobtads-9999.ebuild
bloba55789c9f656393464815b65ff3624c61d62c0cf
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
6 if [ "$PV" == "9999" ]; then
7 # The package uses AM_SILENT_RULES which is only available in automake
8 # 1.11 and later.
9 WANT_AUTOMAKE="1.11"
10 inherit git autotools
12 inherit flag-o-matic games
14 DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
15 HOMEPAGE="http://www.tads.org/frobtads.htm"
16 if [ "$PV" != "9999" ]; then
17 SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz
18 tads2compiler? ( http://www.tads.org/frobtads/${PN}-t2compiler-${PV}.tar.gz )
19 tads3compiler? ( http://www.tads.org/frobtads/${PN}-t3compiler-${PV}.tar.gz )"
20 KEYWORDS="~amd64 ~x86"
21 IUSE="debug tads2compiler tads3compiler"
22 RESTRICT="!tads3compiler? ( test )"
23 else
24 SRC_URI=""
25 EGIT_REPO_URI="git://git.assembla.com/frobtads.git"
26 KEYWORDS=""
27 IUSE="debug"
29 LICENSE="TADS2 TADS3"
30 SLOT="0"
32 DEPEND="sys-libs/ncurses"
33 RDEPEND="${DEPEND}"
35 src_unpack() {
36 if [ "${PV}" != "9999" ]; then
37 unpack ${A}
38 if use tads2compiler; then
39 mv t2compiler/* "${S}"/t2compiler || die "mv t2compiler failed"
41 if use tads3compiler; then
42 mv t3compiler/* "${S}"/t3compiler || die "mv t3compiler failed"
44 else
45 git_src_unpack
46 cd "${S}"
47 einfo "Regenerating autotools files..."
48 eautoreconf
52 src_configure() {
53 append-cxxflags -fno-strict-aliasing
54 egamesconf $(use_enable debug t3debug) || die "egamesconf failed"
57 src_test() {
58 if use debug; then
59 emake -j1 check || die "TADS 3 compiler test suite failed"
62 emake -j1 sample || die "Failed to build test game"
63 ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
64 save
65 testsave.sav
66 restore
67 testsave.sav
68 END_FROB_TEST
69 [[ $? -eq 0 ]] || die "Failed to run test game"
72 src_install() {
73 emake DESTDIR="${D}" install || die "emake install failed"
74 dodoc doc/{AUTHORS,BUGS,NEWS,README,SRC_GUIDELINES,THANKS}
75 prepgamesdirs