games-engines/qtads: fix live ebuild deps
[gentoo-interactive-fiction.git] / games-engines / frobtads / frobtads-9999.ebuild
blobf5951fddea192c9f856d26f82d3437a0c3819559
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=6
5 if [ "$PV" == "9999" ]; then
6 SRC_URI=""
7 EGIT_REPO_URI="https://github.com/realnc/frobtads.git"
8 KEYWORDS=""
9 inherit autotools git-r3
11 inherit eutils
13 DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
14 HOMEPAGE="http://www.tads.org/frobtads.htm"
16 if [ "$PV" != "9999" ]; then
17 SRC_URI="https://github.com/realnc/${PN}/releases/download/${PV}/${P}.tar.bz2"
18 KEYWORDS="~amd64 ~x86"
21 LICENSE="TADS2 TADS3"
22 SLOT="0"
23 RESTRICT="!tads3compiler? ( test )"
24 IUSE="debug frobd +tads2compiler +tads3compiler"
26 DEPEND="sys-libs/ncurses:0
27 net-misc/curl"
28 RDEPEND="${DEPEND}"
30 DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
32 src_unpack() {
33 if [ "${PV}" == "9999" ]; then
34 git-r3_src_unpack
35 cd "${S}"
36 eautoreconf
37 else
38 base_src_unpack
42 src_configure() {
43 econf \
44 $(use_enable debug t3debug) \
45 $(use_enable frobd) \
46 $(use_enable tads2compiler t2-compiler) \
47 $(use_enable tads3compiler t3-compiler)
50 src_test() {
51 #if use debug; then
52 # emake check || die "TADS 3 compiler test suite failed"
53 #fi
55 emake sample
56 ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
57 save
58 testsave.sav
59 restore
60 testsave.sav
61 END_FROB_TEST
62 [[ $? -eq 0 ]] || die "Failed to run test game"