1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 if [ "$PV" == "9999" ]; then
7 EGIT_REPO_URI
="https://github.com/realnc/frobtads.git"
9 inherit autotools git-r3
13 DESCRIPTION
="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
14 HOMEPAGE
="http://www.tads.org/frobtads.htm"
16 if [ "$PV" != "9999" ]; then
17 SRC_URI
="https://github.com/realnc/${PN}/releases/download/${PV}/${P}.tar.bz2"
18 KEYWORDS
="~amd64 ~x86"
23 RESTRICT
="!tads3compiler? ( test )"
24 IUSE
="debug frobd +tads2compiler +tads3compiler"
26 DEPEND
="sys-libs/ncurses:0
30 DOCS
=( doc
/{AUTHORS
,BUGS
,ChangeLog.old
,NEWS
,README
,SRC_GUIDELINES
,THANKS
} )
33 if [ "${PV}" == "9999" ]; then
44 $
(use_enable debug t3debug
) \
46 $
(use_enable tads2compiler t2-compiler
) \
47 $
(use_enable tads3compiler t3-compiler
)
52 # emake check || die "TADS 3 compiler test suite failed"
56 .
/frob
-i plain
-p samples
/sample.t3
<<- END_FROB_TEST
62 [[ $?
-eq 0 ]] || die
"Failed to run test game"