2 # Sample debian.rules file - for GNU Hello (1.3).
3 # Copyright 1994,1995 by Ian Jackson.
4 # I hereby give you perpetual unlimited permission to copy,
5 # modify and relicense this file, provided that you do not remove
6 # my name from the file itself. (I assert my moral right of
7 # paternity under the Copyright, Designs and Patents Act 1988.)
8 # This file may have to be extensively modified
9 # Copyright 1996 by Kevin Dalley
21 .
/configure
--prefix=/usr
--localstatedir
=/var
/lib
/locate \
22 --libexecdir
='$${prefix}/lib/locate' \
23 --mandir='$${prefix}/share/man' \
24 --infodir='$${prefix}/share/info'
26 CC
="$(CC)" CFLAGS
="$(CFLAGS)" LDFLAGS
="$(LDFLAGS)"
27 cd doc
; makeinfo find.texi
33 -$(MAKE
) -i
distclean ||
$(MAKE
) -f Makefile.in
distclean
34 -rm -rf
*~ debian
/tmp debian
/*~ debian
/files
*
36 binary-indep
: checkroot build
38 # There are no architecture-independent files to be uploaded
39 # generated by this package. If there were any they would be
42 binary-arch
: checkroot build
45 install -d debian
/tmp debian
/tmp
/DEBIAN
46 install -d debian
/tmp
/usr
/share
/doc
/$(package
)
47 install -d debian
/tmp
/usr
/bin
48 install -d debian
/tmp
/usr
/lib
49 install -d debian
/tmp
/usr
/lib
/locate
50 install -d debian
/tmp
/etc
51 install -d debian
/tmp
/etc
/cron.daily
52 install -d debian
/tmp
/var
53 install -d debian
/tmp
/var
/lib
54 install -d debian
/tmp
/var
/lib
/locate
55 install debian
/postinst debian
/prerm debian
/preinst debian
/tmp
/DEBIAN
/.
56 install -m
0644 debian
/conffiles debian
/tmp
/DEBIAN
/.
57 install debian
/cron.find debian
/tmp
/etc
/cron.daily
/find
58 install -m
0644 debian
/updatedb.conf debian
/tmp
/etc
/updatedb.conf
59 $(MAKE
) prefix=`pwd`/debian
/tmp
/usr \
60 localstatedir
=`pwd`/debian
/tmp
/var
/lib
/locate \
61 CC
="$(CC)" CFLAGS
="$(CFLAGS)" LDFLAGS
="$(LDFLAGS)" \
62 INSTALL_PROGRAM
='install -c' \
64 install -d debian
/tmp
/usr
/share
/doc-base
65 install -m
0644 debian
/doc-base \
66 debian
/tmp
/usr
/share
/doc-base
/findutils
67 gzip
-9v debian
/tmp
/usr
/share
/info/*
68 gzip
-9v debian
/tmp
/usr
/share
/man
/man
[15]/*
69 install -m
0644 debian
/copyright debian
/tmp
/usr
/share
/doc
/$(package
)/.
70 install -m
0644 debian
/changelog \
71 debian
/tmp
/usr
/share
/doc
/$(package
)/changelog.Debian
72 gzip
-9v debian
/tmp
/usr
/share
/doc
/$(package
)/changelog.Debian
73 for file in ChangeLog INSTALL NEWS README TODO
; do \
74 install -m
0644 $$file \
75 debian
/tmp
/usr
/share
/doc
/$(package
);\
76 gzip
-9v debian
/tmp
/usr
/share
/doc
/$(package
)/$$file;\
78 ln
-s ChangeLog.gz debian
/tmp
/usr
/share
/doc
/$(package
)/changelog.gz
79 install -m
0644 debian
/README.debian \
80 debian
/tmp
/usr
/share
/doc
/$(package
)
81 dpkg-shlibdeps
-dPre-Depends debian
/tmp
/usr
/bin
/find \
82 debian
/tmp
/usr
/bin
/locate debian
/tmp
/usr
/bin
/xargs
84 dpkg
--build debian
/tmp ..
87 test -f find
/find.c
-a
-f debian
/rules
90 # Below here is fairly generic really
92 binary
: binary-indep binary-arch
95 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
99 test root
= "`whoami`"
101 .PHONY
: binary binary-arch binary-indep
clean checkroot