oops! fix typo in r3829
[ess.git] / RPM.spec
blobbc819878aa121e580ecdcab891ae298c4c3e8f77
1 # This is an RPM spec file that specifies how to package
2 # ESS for Fedora Core Linux and, possibly, similar systems.
3 # $Id: emacs-ess.spec,v 1.9 2004/10/15 16:44:43 thor Exp $
5 %define name emacs-ess
6 %define version 5.3.6
7 %define release 1.tgm
8 Summary: Emacs Speaks Statistics add-on package for Emacs
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Copyright: GPL
13 Group: Applications/Editors
14 Source: http://ESS.R-project.org/downloads/ess/ess-%{version}.tar.gz
15 URL: http://ESS.R-project.org/
16 Packager: Tom Moertel <tom-rpms@moertel.com>
17 BuildRoot: %{_tmppath}/%{name}-root
18 Prefix: %{_prefix}
19 BuildArchitectures: noarch
20 BuildRequires: emacs
21 Requires: emacs
23 %description
24 This package provides Emacs Speaks Statistics (ESS), which provides
25 Emacs-based front ends for popular statistics packages.
27 ESS provides an intelligent, consistent interface between the user and
28 the software. ESS interfaces with S-PLUS, R, SAS, BUGS and other
29 statistical analysis packages under the Unix, Microsoft Windows, and
30 Apple Mac OS operating systems. ESS is a package for the GNU Emacs
31 and XEmacs text editors whose features ESS uses to streamline the
32 creation and use of statistical software. ESS knows the syntax and
33 grammar of statistical analysis packages and provides consistent
34 display and editing features based on that knowledge. ESS assists in
35 interactive and batch execution of statements written in these
36 statistical analysis languages.
38 %prep
39 %setup -n ess-%{version}
40 ( cd doc && chmod u+w html info ) # fix perms to ensure builddir can be deleted
42 %build
43 make
45 # create an init file that is loaded when a user starts up emacs to
46 # tell emacs to autoload our package's Emacs code when needed
47 cat > %{name}-init.el <<"EOF"
48 ;;; Set up %{name} for Emacs.
49 ;;;
50 ;;; This file is automatically loaded by emacs's site-start.el
51 ;;; when you start a new emacs session.
53 (require 'ess-site)
55 EOF
57 # create a README.RPM file to document any quirks of this package
58 cat > README.RPM <<EOF
59 README for %{name}-%{version}-%{release} RPM package
61 Generally, there will be no need to modify your .emacs file in order
62 to use the features of this package -- they are enabled by default
63 when you start Emacs.
65 Cheers,
66 Tom
69 Tom Moertel <tom-rpms@moertel.com>
70 EOF
73 %install
74 %{__rm} -rf ${RPM_BUILD_ROOT}
75 INITDIR=${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/site-start.d
76 PKGLISP=${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}-%{version}
77 INFODIR=${RPM_BUILD_ROOT}%{_infodir}
78 %{__install} -D %{name}-init.el $INITDIR/%{name}-init.el
79 %{__install} -d $PKGLISP
80 %{__install} -d $INFODIR
81 %{__make} install \
82 PREFIX=${RPM_BUILD_ROOT}%{_prefix} \
83 LISPDIR=$PKGLISP \
84 INFODIR=$INFODIR
85 %{__rm} -f $INFODIR/dir # don't package but instead update in pre and post
86 %{__cp} -a etc $PKGLISP # tuck ess's /etc into lisp dir for easy transport
88 # Uncomment to print the README file after install.
90 # %post
91 # echo
92 # cat %{_defaultdocdir}/%{name}-%{version}/README.RPM
93 # echo
95 %clean
96 %{__rm} -rf ${RPM_BUILD_ROOT}
98 %files
99 %defattr(-,root,root)
100 %doc README README.RPM ANNOUNCE COPYING VERSION ChangeLog doc
101 %dir %{_datadir}/emacs/site-lisp/%{name}-%{version}
102 %{_datadir}/emacs/site-lisp/%{name}-%{version}/*
103 %{_datadir}/emacs/site-lisp/site-start.d/*
104 %{_infodir}/*.gz
106 %post
107 [ -f /usr/share/info/ess.info.gz ] && \
108 /sbin/install-info /usr/share/info/ess.info.gz /usr/share/info/dir || :
110 %preun
111 if [ $1 = 0 ]; then
112 [ -f /usr/share/info/ess.info.gz ] && \
113 /sbin/install-info --delete /usr/share/info/ess.info.gz \
114 /usr/share/info/dir || :
118 %changelog
119 * Fri Oct 15 2004 Tom Moertel <thor@bifur.lab01.moertel.com> 5.2.3-1.tgm
120 - Updated to ESS 5.2.3.
122 * Fri Aug 27 2004 Tom Moertel <thor@bifur.lab01.moertel.com> 5.2.2-3.tgm
123 - Updated ESS URL.
124 - Fixed Summary.
126 * Fri Aug 27 2004 Tom Moertel <thor@bifur.lab01.moertel.com> 5.2.2-2.tgm
127 - Fixed bug: Forgot to include ESS's etc/ directory.
129 * Thu Aug 26 2004 Tom Moertel <thor@bifur.lab01.moertel.com> 5.2.2-1.tgm
130 - Initial build.