3 # see: dh_installdeb(1)
7 # summary of how this script can be called:
8 # * <postinst> `configure' <most-recently-configured-version>
9 # * <old-postinst> `abort-upgrade' <new version>
10 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
13 # <failed-install-package> <version> `removing'
14 # <conflicting-package> <version>
15 # for details, see /usr/doc/packaging-manual/
17 # quoting from the policy:
18 # Any necessary prompting should almost always be confined to the
19 # post-installation script, and should be protected with a conditional
20 # so that unnecessary prompting doesn't happen if a package's
21 # installation fails and the `postinst' is called with `abort-upgrade',
22 # `abort-remove' or `abort-deconfigure'.
26 update-alternatives
--quiet --install /usr
/bin
/links links \
27 /usr
/bin
/elinks
20 --slave /usr
/share
/man
/man
1/links
.1.gz \
28 links
.1.gz
/usr
/share
/man
/man
1/elinks
.1.gz
29 update-alternatives
--quiet --install /usr
/bin
/www-browser www-browser \
31 --slave /usr
/share
/man
/man
1/www-browser
.1.gz www-browser
.1.gz \
32 /usr
/share
/man
/man
1/elinks
.1.gz
34 # Purge the debconf database we no longer need.
35 if [ -e /usr
/share
/debconf
/confmodule
]; then
36 .
/usr
/share
/debconf
/confmodule
43 abort-upgrade|abort-remove|abort-deconfigure
)
48 echo "postinst called with unknown argument \`$1'" >&2
53 # dh_installdeb will replace this with shell code automatically
54 # generated by other debhelper scripts.