bug 1097: Better digest proxy authentication.
[elinks.git] / contrib / debian / elinks.postinst
blobf4aecabbb9bff9311a594d237a30609c8814e956
1 #! /bin/sh
2 # postinst for elinks
3 # see: dh_installdeb(1)
5 set -e
7 # summary of how this script can be called:
8 # * <postinst> `configure' <most-recently-configured-version>
9 # * <old-postinst> `abort-upgrade' <new version>
10 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
11 # <new-version>
12 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
13 # <failed-install-package> <version> `removing'
14 # <conflicting-package> <version>
15 # for details, see /usr/doc/packaging-manual/
17 # quoting from the policy:
18 # Any necessary prompting should almost always be confined to the
19 # post-installation script, and should be protected with a conditional
20 # so that unnecessary prompting doesn't happen if a package's
21 # installation fails and the `postinst' is called with `abort-upgrade',
22 # `abort-remove' or `abort-deconfigure'.
24 case "$1" in
25 configure)
26 update-alternatives --quiet --install /usr/bin/links links \
27 /usr/bin/elinks 20 --slave /usr/share/man/man1/links.1.gz \
28 links.1.gz /usr/share/man/man1/elinks.1.gz
29 update-alternatives --quiet --install /usr/bin/www-browser www-browser \
30 /usr/bin/elinks 35 \
31 --slave /usr/share/man/man1/www-browser.1.gz www-browser.1.gz \
32 /usr/share/man/man1/elinks.1.gz
34 # Purge the debconf database we no longer need.
35 if [ -e /usr/share/debconf/confmodule ]; then
36 . /usr/share/debconf/confmodule
37 db_version 2.0
38 db_purge
43 abort-upgrade|abort-remove|abort-deconfigure)
48 echo "postinst called with unknown argument \`$1'" >&2
49 exit 0
51 esac
53 # dh_installdeb will replace this with shell code automatically
54 # generated by other debhelper scripts.
56 #DEBHELPER#
58 exit 0