wmacpi: Bump to version 2.2rc1.
[dockapps.git] / wmacpi / debian / rules
blob5cc82ce497466f43c984e6129e2ab99309cfff5b
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 INSTALLDIR=$(CURDIR)/debian/wmacpi
10 # These are used for cross-compiling and for saving the configure script
11 # # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16 CFLAGS = "-Wall -g -O0"
17 else
18 CFLAGS = "-Wall -g -O2"
19 endif
21 configure: configure-stamp
22 configure-stamp:
23 dh_testdir
25 touch configure-stamp
27 build: configure-stamp build-stamp
28 build-stamp:
29 dh_testdir
31 # Add here commands to compile the package.
32 $(MAKE)
34 touch build-stamp
36 clean:
37 dh_testdir
38 dh_testroot
39 rm -f build-stamp configure-stamp
41 # Add here commands to clean up after the build process.
42 -$(MAKE) clean-all
44 dh_clean
46 install: build
47 dh_testdir
48 dh_testroot
49 dh_clean -k
50 dh_installdirs
52 # Add here commands to install the package into debian/wmacpi.
53 install -o root -g root -m 755 wmacpi $(INSTALLDIR)/usr/bin/
54 # install -o root -g root -m 755 acpi-ng $(INSTALLDIR)/usr/bin/
57 # Build architecture-independent files here.
58 binary-indep: build install
59 # We have nothing to do by default.
61 # Build architecture-dependent files here.
62 binary-arch: build install
63 dh_testdir
64 dh_testroot
65 # dh_installdebconf
66 dh_installdocs
67 # dh_installexamples
68 dh_installmenu
69 # dh_installemacsen
70 # dh_installpam
71 # dh_installinit
72 # dh_installcron
73 dh_installman wmacpi.1 # acpi.1
74 # dh_installinfo
75 # dh_undocumented
76 dh_installchangelogs ChangeLog
77 dh_link
78 dh_strip
79 dh_compress
80 dh_fixperms
81 # dh_makeshlibs
82 dh_installdeb
83 # dh_perl
84 dh_shlibdeps
85 dh_gencontrol
86 dh_md5sums
87 dh_builddeb
89 binary: binary-indep binary-arch
90 .PHONY: build clean binary-indep binary-arch binary install configure