2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
8 INSTALLDIR
=$(CURDIR
)/debian
/wmacpi
10 # These are used for cross-compiling and for saving the configure script
11 # # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
13 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
15 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
16 CFLAGS
= "-Wall -g -O0"
18 CFLAGS
= "-Wall -g -O2"
21 configure
: configure-stamp
27 build
: configure-stamp build-stamp
31 # Add here commands to compile the package.
39 rm -f build-stamp configure-stamp
41 # Add here commands to clean up after the build process.
52 # Add here commands to install the package into debian/wmacpi.
53 install -o root
-g root
-m
755 wmacpi
$(INSTALLDIR
)/usr
/bin
/
54 # install -o root -g root -m 755 acpi-ng $(INSTALLDIR)/usr/bin/
57 # Build architecture-independent files here.
58 binary-indep
: build
install
59 # We have nothing to do by default.
61 # Build architecture-dependent files here.
62 binary-arch
: build
install
73 dh_installman wmacpi
.1 # acpi.1
76 dh_installchangelogs ChangeLog
89 binary
: binary-indep binary-arch
90 .PHONY
: build
clean binary-indep binary-arch binary
install configure