3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
16 # This has to be exported to make some magic below work.
19 export DH_GOPKG
:= github.com
/Debian
/dcs
21 override_dh_auto_build
:
22 dh_auto_build
-- -ldflags "-X github.com/Debian/dcs/cmd/dcs-web/common.Version $(shell date -u +%Y-%m-%d.%H%M)"
23 # adding this tag disables usage of ranking database: -tags 'no_ranking_db'
25 # FIXME: tests currently fail
26 override_dh_auto_test
:
29 dh
$@
--buildsystem
=golang
--with
=golang