dd: improve doc of stderr output
[coreutils.git] / README-prereq
blobfdf89fecdea494300e143454d1522d968b41a971
1 This gives some notes on obtaining the tools required for development.
2 I.e., the tools checked for by the bootstrap script and include:
4 - Autoconf  <https://www.gnu.org/software/autoconf/>
5 - Automake  <https://www.gnu.org/software/automake/>
6 - Bison     <https://www.gnu.org/software/bison/>
7 - Gettext   <https://www.gnu.org/software/gettext/>
8 - Git       <https://git-scm.com/>
9 - Gperf     <https://www.gnu.org/software/gperf/>
10 - Gzip      <https://www.gnu.org/software/gzip/>
11 - Perl      <https://www.cpan.org/>
12 - Rsync     <https://rsync.samba.org/>
13 - Tar       <https://www.gnu.org/software/tar/>
14 - Texinfo   <https://www.gnu.org/software/texinfo/>
16 Note please try to install/build official packages for your system.
17 If these programs are not available use the following instructions
18 to build them and install the results into a directory that you will
19 then use when building this package.
21 Even if the official version of a package for your system is too old,
22 please install it, as it may be required to build the newer versions.
23 The examples below install into $HOME/coreutils/deps/, so if you are
24 going to follow these instructions, first ensure that your $PATH is
25 set correctly by running this command:
27   prefix=$HOME/coreutils/deps
28   export PATH=$prefix/bin:$PATH
30 * autoconf *
32   # Note Autoconf 2.62 or newer is needed to build automake-1.11.2
33   # but we specify 2.64 here as that's what coreutils requires.
34   # Please use the latest stable release version as indicated by git tags.
35   git clone --depth=1 git://git.sv.gnu.org/autoconf.git
36   cd autoconf
37   git checkout v2.64
38   autoreconf -vi
39   ./configure --prefix=$prefix
40   make install
42 * automake *
44   # Note help2man is required to build automake fully
45   git clone git://git.sv.gnu.org/automake.git
46   cd automake
47   git checkout v1.11.2
48   ./bootstrap
49   ./configure --prefix=$prefix
50   make install
52 This package uses XZ utils (successor to LZMA) to create
53 a compressed distribution tarball.  Using this feature of Automake
54 requires version 1.10a or newer, as well as the xz program itself.
56 * xz *
58   git clone git://ctrl.tukaani.org/xz.git
59   cd xz
60   ./autogen.sh
61   ./configure --prefix=$prefix
62   make install
64 Now you can build this package as described in README-hacking.