Correct build of python extension.
[bcusdk.git] / debian / rules
blob1679cd6dc97ef317d3d6992f3b39276160b433aa
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 PACKAGE=tmp
7 ifeq (,$(DEB_BUILD_GNU_TYPE))
8 include /usr/share/dbs/dpkg-arch.mk
9 endif
11 CONFARGS = -v \
12 --prefix=/usr \
13 --infodir=/usr/share/info \
14 --mandir=/usr/share/man \
15 --libexecdir=/usr/lib \
16 --enable-ft12 \
17 --enable-pei16 \
18 --enable-tpuart \
19 --enable-pei16s \
20 --enable-tpuarts \
21 --enable-eibnetip \
22 --enable-eibnetipserver \
23 --enable-groupcache \
24 --enable-usb \
25 --enable-eibnetiptunnel
27 srcdir=src
29 # Patches
30 #patch_stamp=patch-stamp
31 #debian_patches = gcc_avr_fixed_reg
32 #include /usr/src/toolchain/patches/gcc/rules.patch
34 # Uncomment this to turn on verbose mode.
35 export DH_VERBOSE=1
37 include /usr/share/dbs/dbs-build.mk
39 #unpack: unpack-stamp
40 #unpack-stamp:
41 # tar xjf /usr/src/toolchain/gcc.tar.bz2
42 # mv gcc-* src
43 # mkdir build
45 # touch unpack-stamp
47 configure: configure-stamp
48 configure-stamp: $(patched)
49 dh_testdir
50 # Add here commands to configure the package.
51 ./configure $(CONFARGS)
52 touch configure-stamp
54 build: configure-stamp build-stamp
55 build-stamp: $(patched)
56 dh_testdir
58 # Add here commands to compile the package.
59 $(MAKE)
60 #/usr/bin/docbook-to-man debian/$(PACKAGE).sgml > $(PACKAGE).1
62 touch build-stamp
64 clean:
65 dh_testdir
66 dh_testroot
67 rm -f build-stamp configure-stamp
69 # Add here commands to clean up after the build process.
70 -$(MAKE) distclean
71 find -type l -exec rm {} \;
72 rm -rf $(STAMP_DIR) $(SOURCE_DIR)
74 dh_clean
76 install: build
77 dh_testdir
78 dh_testroot
79 dh_clean -k
80 dh_installdirs
82 # Add here commands to install the package into debian/$(PACKAGE).
83 $(MAKE) install DESTDIR=$(CURDIR)/debian/$(PACKAGE)/
85 # Must not depend on anything. This is to be called by
86 # binary-arch/binary-indep
87 # in another 'make' thread.
88 binary-common:
89 dh_testdir
90 dh_testroot
91 dh_install --sourcedir=debian/tmp
92 dh_installchangelogs
93 dh_installdocs -A README
94 dh_installexamples
95 # dh_installmenu
96 # dh_installdebconf
97 # dh_installlogrotate
98 # dh_installemacsen
99 # dh_installpam
100 # dh_installmime
101 # dh_installinit
102 # dh_installcron
103 # dh_installinfo
104 dh_installman
105 dh_link
106 dh_strip -Xusr/lib/bcusdk/lib
107 dh_compress
108 dh_fixperms
109 # dh_perl
110 # dh_python
111 dh_makeshlibs
112 dh_installdeb
113 dh_shlibdeps
114 dh_gencontrol
115 dh_md5sums
116 dh_builddeb
117 # Build architecture independant packages using the common target.
118 binary-indep: install
119 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
121 # Build architecture dependant packages using the common target.
122 binary-arch: install
123 $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
126 binary: binary-indep binary-arch
127 .PHONY: build clean binary-indep binary-arch binary-common binary install configure