- opensync plugin:
[barry.git] / rpm / barry.spec
blobcf902baf24063224aaf49604edba04ed5aefafac
1 ## pass in '--with gui' to build the GUI tools
2 # ex.: rpmbuild -ba barry.spec --with gui
4 ## pass in '--with opensync' to build the opensync plugin
5 # ex.: rpmbuild -ba barry.spec --with opensync
8 # When building on SuSE, remove the "-devel" on the following packages:
9 # libusb-devel
10 # gtkmm24-devel
12 # SuSE also seems to name libglademm24 differently:
13 # libglademm
16 # newer bcond_with() macros are not available on RHEL4/CentOS4 and below
17 %{?_with_gui: %define with_gui 1}
18 %{!?_with_gui: %define with_gui 0}
19 %{?_with_opensync: %define with_opensync 1}
20 %{!?_with_opensync: %define with_opensync 0}
22 Summary: BlackBerry(tm) Desktop for Linux
23 Name: barry
24 Version: 0.8
25 Release: 1
26 Group: Applications/Productivity
27 License: GPL
28 Source: %{name}-%{version}.tar.gz
29 URL: http://www.netdirect.ca/downloads/barry
30 Vendor: Net Direct Inc.
31 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
32 BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, openssl-devel
34 %define barryroot %{_builddir}/%{name}-%{version}
36 %description
37 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
38 is a registered trademark of Research in Motion Limited.)
41 %package -n libbarry
42 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
43 Group: Development/Libraries
44 Requires: libusb openssl boost
46 %description -n libbarry
47 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
48 is a registered trademark of Research in Motion Limited.)
50 This package contains the library files, license agreement, README file,
51 and most other assorted documentation common to all sub-packages. You most
52 likely want to also install barry-util and barry-gui.
55 %package -n libbarry-devel
56 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
57 Group: Development/Libraries
58 Requires: libbarry libusb-devel openssl-devel boost-devel
60 %description -n libbarry-devel
61 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
62 is a registered trademark of Research in Motion Limited.)
64 This package contains the development library files for Barry, libbarry.
67 %package util
68 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
69 Group: Applications/Productivity
70 Requires: libbarry
71 Conflicts: barry-bcharge
73 %description util
74 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
75 is a registered trademark of Research in Motion Limited.)
77 This package contains the commandline tools bcharge, btool, breset and others
78 which will enable you to charge your device with a proper 500mA and be able
79 to access the data on the device in many ways.
82 %if %{with_gui}
83 %package gui
84 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
85 Group: Applications/Productivity
86 Requires: libbarry gtkmm24 libglademm24 libtar
87 BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
89 %description gui
90 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
91 is a registered trademark of Research in Motion Limited.)
93 This package contains the GUI applications built on top of libbarry.
94 %endif
97 %if %{with_opensync}
98 %package opensync
99 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
100 Group: Applications/Productivity
101 Requires: libbarry libopensync
102 BuildRequires: libopensync-devel
104 %description opensync
105 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
106 is a registered trademark of Research in Motion Limited.)
108 This package contains the opensync plugin.
109 %endif
111 %prep
112 %setup -q
114 %build
115 # main tree
116 %{configure} --with-boost=%{_prefix}
117 %{__make} %{?_smp_mflags}
119 # gui tree
120 %if %{with_gui}
121 cd gui/
122 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src"
123 %{__make} %{?_smp_mflags}
124 cd ../
125 %endif
127 # opensync tree
128 %if %{with_opensync}
129 cd opensync-plugin/
130 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src"
131 %{__make} %{?_smp_mflags}
132 cd ../
133 %endif
135 %install
136 # main tree
137 %{__make} DESTDIR=%{buildroot} install
138 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
139 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
140 %{__mkdir_p} %{buildroot}%{_sysconfdir}/security/console.perms.d
141 %{__cp} udev/10-blackberry.perms %{buildroot}%{_sysconfdir}/security/console.perms.d/
143 # gui tree
144 %if %{with_gui}
145 cd gui/
146 %{__make} DESTDIR=%{buildroot} install
147 cd ../
148 %endif
150 # opensync tree
151 %if %{with_opensync}
152 cd opensync-plugin/
153 %{__make} DESTDIR=%{buildroot} install
154 cd ../
155 %endif
157 %files -n libbarry
158 %defattr(-,root,root)
159 %attr(-,root,root) %{_libdir}/*.so*
160 %doc AUTHORS ChangeLog COPYING NEWS README
162 %files -n libbarry-devel
163 %defattr(-,root,root)
164 %doc examples/*.cc examples/*.am
165 %attr(0644,root,root) %{_includedir}/barry/*
166 %attr(0644,root,root) %{_libdir}/*.a
167 %attr(0755,root,root) %{_libdir}/*.la
168 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
169 %doc COPYING TODO doc/*
171 %files util
172 %defattr(-,root,root)
173 %attr(0755,root,root) %{_sbindir}/bcharge
174 %attr(0755,root,root) %{_sbindir}/breset
175 %attr(0755,root,root) %{_sbindir}/pppob
176 %attr(0755,root,root) %{_bindir}/btool
177 %attr(0755,root,root) %{_bindir}/upldif
178 %attr(0755,root,root) %{_bindir}/ktrans
179 %attr(0755,root,root) %{_bindir}/translate
180 %attr(0644,root,root) %{_mandir}/man1/btool*
181 %attr(0644,root,root) %{_mandir}/man1/bcharge*
182 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
183 %attr(0644,root,root) %config %{_sysconfdir}/security/console.perms.d/*
184 %doc COPYING
186 %if %{with_gui}
187 %files gui
188 %defattr(-,root,root)
189 %attr(0755,root,root) %{_bindir}/barrybackup
190 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
191 %doc COPYING
192 %endif
194 %if %{with_opensync}
195 %files opensync
196 %defattr(-,root,root)
197 %attr(0755,root,root) %{_libdir}/opensync/plugins/*
198 %attr(0644,root,root) %{_datadir}/opensync/defaults/*
199 %doc COPYING
200 %endif
202 %clean
203 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
204 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
206 %post -n libbarry
207 /sbin/ldconfig
209 %postun -n libbarry
210 /sbin/ldconfig
212 %changelog
213 * Fri May 04 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
214 - version bump
216 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
217 - added pppob to utils
219 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
220 - removed barry base package that only contained docs, and put docs in libbarry*
221 - changed barrybackup reference to barry-gui
222 - removed the patch step, as version 0.7 shouldn't need it
223 - added license file to each package
225 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
226 - initial build
227 - adding udev and console perms patch for raw 0.6