3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
16 # This has to be exported to make some magic below work.
23 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
29 configure
: configure-stamp
33 # Add here commands to configure the package.
39 build
: build-arch build-indep
41 build-arch
: build-arch-stamp
42 build-arch-stamp
: configure-stamp
44 # Add here commands to compile the arch part of the package.
45 .
/configure
--prefix=/usr
--with-boost
=/usr
47 (cd gui
&& .
/configure PKG_CONFIG_PATH
="..:$PKG_CONFIG_PATH" CXXFLAGS
="-I../.." LDFLAGS
="-L../../src" --prefix=/usr
)
50 touch build-arch-stamp
52 build-indep
: build-indep-stamp
53 build-indep-stamp
: configure-stamp
55 # Add here commands to compile the indep part of the package.
57 #touch build-indep-stamp
62 rm -rf
$(CURDIR
)/debian
/everything
63 rm -f build-arch-stamp build-indep-stamp
#CONFIGURE-STAMP#
65 # Add here commands to clean up after the build process.
67 (cd gui
&& $(MAKE
) distclean)
69 dh_clean
--exclude .
/src
/Makefile.orig
71 install: install-indep install-arch
75 dh_clean
-k
-i
--exclude .
/src
/Makefile.orig
78 # Add here commands to install the indep part of the package into
79 # debian/<package>-doc.
87 dh_clean
-k
-s
--exclude .
/src
/Makefile.orig
90 # Add here commands to install the arch part of the package into
93 # Install EVERYTHING from the base library portion into
94 # a temporary directory, then split them out into their
95 # respective package directories. Anything left behind
96 # needs to be looked at!
97 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/everything
99 # Move the basic libbarry files
100 install -d
$(CURDIR
)/debian
/libbarry
/usr
/lib
101 mv
$(CURDIR
)/debian
/everything
/usr
/lib
/libbarry.so.
* $(CURDIR
)/debian
/libbarry
/usr
/lib
103 # Move the devel library files
104 install -d
$(CURDIR
)/debian
/libbarry-dev
/usr
/include
105 mv
$(CURDIR
)/debian
/everything
/usr
/include/* $(CURDIR
)/debian
/libbarry-dev
/usr
/include
106 mv
$(CURDIR
)/debian
/everything
/usr
/lib
$(CURDIR
)/debian
/libbarry-dev
/usr
108 # Move the command line utils
109 mkdir
$(CURDIR
)/debian
/barry-util
/usr
110 mv
$(CURDIR
)/debian
/everything
/usr
/bin
$(CURDIR
)/debian
/barry-util
/usr
111 mv
$(CURDIR
)/debian
/everything
/usr
/sbin
$(CURDIR
)/debian
/barry-util
/usr
112 install -d
$(CURDIR
)/debian
/barry-util
/usr
/share
113 mv
$(CURDIR
)/debian
/everything
/usr
/share
/man
$(CURDIR
)/debian
/barry-util
/usr
/share
115 # Install udev rules for the barry-util package
116 install -d
$(CURDIR
)/debian
/barry-util
/etc
/udev
/rules.d
117 install -m
0644 $(CURDIR
)/udev
/10-blackberry.rules.Debian
$(CURDIR
)/debian
/barry-util
/etc
/udev
/rules.d
/10-blackberry.rules
119 # The GUI has its own install, so we go directly to target package dir
120 (cd gui
&& $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/barrybackup-gui
)
122 # Display anything remaining
123 echo
"NOTE: IF ANYTHING IS LISTED HERE, IT IS NOT BEING PACKAGED:"
124 find
$(CURDIR
)/debian
/everything
128 # Must not depend on anything. This is to be called by
129 # binary-arch/binary-indep
130 # in another 'make' thread.
134 dh_installchangelogs ChangeLog
139 # dh_installlogrotate
159 # Build architecture independant packages using the common target.
160 binary-indep
: build-indep install-indep
161 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
163 # Build architecture dependant packages using the common target.
164 binary-arch
: build-arch install-arch
165 $(MAKE
) -f debian
/rules DH_OPTIONS
=-a binary-common
167 binary
: binary-arch binary-indep
168 .PHONY
: build
clean binary-indep binary-arch binary
install install-indep install-arch configure