lib: removed virtual inheritance from some ALX parser classes
[barry.git] / opensync-plugin-0.4x / debian / rules
blob7a57c5143538feba61490de2e6815aa5de8385eb
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware(must be full path! CURDIR does this)
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=opensync-plugin-barry-4x
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 #DEB_CONFIGURE_EXTRA_FLAGS :=
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 post-patches::
27 @rm -f $(CURDIR)/deb_srcdir
28 @ln -s $(DEB_SRCDIR) $(CURDIR)/deb_srcdir
29 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
31 makebuilddir::
32 # This rule is meant for the parent debian/rules to be able to call
33 # us, and give us the location of a pre-built libbarry to
34 # insert into our DESTDIR, to avoid needing to install
35 # libbarry-dev to build this package.
36 # If TREE_BUILD_DIR is empty, nothing happens.
37 (if [ -n "$(TREE_BUILD_DIR)" ] ; then \
38 cd $(TREE_BUILD_DIR) && \
39 make DESTDIR=$(DEB_DESTDIR) install && \
40 rm -f `find $(DEB_DESTDIR) -name "*.la"` && \
41 cp $(TREE_BUILD_DIR)/debian/libbarry*/DEBIAN/shlibs \
42 $(CURDIR)/debian/shlibs.local ; \
43 fi)
45 clean::
46 -@rm -f $(CURDIR)/deb_srcdir