tools: added unistd.h to brawchannel_unix.cc for gcc 4.7+
[barry.git] / opensync-plugin-0.4x / debian / rules
blobc55611722cf4b93816d2d9c0e2246dd64872a5fa
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
15 # in which directory to build
16 DEB_BUILDDIR = .
18 # in which directory to install the sofware(must be full path! CURDIR does this)
19 DEB_DESTDIR = $(CURDIR)/debian/tmp
21 #CDBS automatically handles common flags to pass to the configure script,
22 #but it is possible to give some extra parameters :
23 DEB_CONFIGURE_EXTRA_FLAGS := --enable-rpathhack
24 COMMON_CONFIGURE_FLAGS := --prefix=/usr
25 DEB_INSTALL_DOCS_ALL =
27 post-patches::
28 @rm -f $(CURDIR)/deb_srcdir
29 @ln -s $(DEB_SRCDIR) $(CURDIR)/deb_srcdir
30 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
32 makebuilddir::
33 # This rule is meant for the parent debian/rules to be able to call
34 # us, and give us the location of a pre-built libbarry to
35 # insert into our DESTDIR, to avoid needing to install
36 # libbarry-dev to build this package.
37 # If TREE_BUILD_DIR is empty, nothing happens.
38 (if [ -n "$(TREE_BUILD_DIR)" ] ; then \
39 cd $(TREE_BUILD_DIR) && \
40 make DESTDIR=$(DEB_DESTDIR) install && \
41 rm -f `find $(DEB_DESTDIR) -name "*.la"` && \
42 cp $(TREE_BUILD_DIR)/debian/libbarry*/DEBIAN/shlibs \
43 $(CURDIR)/debian/shlibs.local ; \
44 fi)
46 clean::
47 -@rm -f $(CURDIR)/deb_srcdir